Firstly, I'll answer my own question by saying that I don't think I have broken it.

However, is it possible I could have? (and also possibly, the power supply I was testing).

I am quite new to electronics and recently purchased a Fluke 115. Having watched a few YouTube videos and looking through its manual, I decided to measure Voltage (V) and Current (A) between a DC power supply and a Mini-ITX motherboard.

So, I Connected the black lead to the common terminal, and the red lead to the V terminal. Stuck the ends of the probes on the outside and inside of the barrel jack. Set it to Volts DC. Measuring voltage fine with normal/reverse polarity. (+/-).

Now I went to try and measure current... sigh...

Using a lead I made with a Mini-fit JR connector on one end, and a soldered DC jack on the other, I snipped the positive wire so I could break the circuit and put the probes in-line. I fitted some crocodile clip accessories from Fluke to the probes, set it to Amps DC and tried measuring. I was getting a zero reading, so I must have done something wrong?

Stupidly, I thought, hmm... I will just double check the meter is still working and tried to measure volts again. Took the croc-clips off, stuck the probes in the jack and pop/flash, a spark appeared. Pulled away quickly.

I had left the red lead in the A terminal :(

Here is why I don't think I've broken it (or the power supply):

  • Firstly, I did a fuse check by connecting one probe to the V terminal, and putting its probe into the A terminal. Setting it to Ohms, it gave me a reading of 0.1/0.2 Ohms. So the fuse doesn't appear to be blown.

  • After actually connecting the probes in the correct way, I am getting the correct Voltage still.

  • Also I figured out why the current wasn't working, and I'm now getting an acceptable reading of Amps.

Some additional info:

  • The power supply outputs 19V, and can supply up to 6.32A.

  • Inspecting my probes, and the black probe where the spark came from has a tiny little dark patch (very very small).

I normally wouldn't care, but the meter was expensive with it being a Fluke, but I wanted something accurate. I also don't take chances with anything electrical due to possible shock/fire risks.

Then again, I realise I am an idiot for quickly rushing ahead and measuring things.

But, do you think I've broken anything?

  • 1
    \$\begingroup\$ I would check to see if the burden voltage listed in the manual is still accurate. \$\endgroup\$ Jul 12, 2015 at 16:59
  • 2
    \$\begingroup\$ I don't expect you have damaged your meter. I'm sure that many of us have accidentally left the meter in the Amps position and then tried to measure voltage! The meter designer will have predicted that can happen and has an internal fuse to protect it although in this case it looks like it survived or you wouldn't be able to measure current. In the future if(when) you do it again and current measurement doesn't work you will need to open up the meter and replace the fuse. \$\endgroup\$ Jul 12, 2015 at 17:22
  • \$\begingroup\$ Yes, it's possible you could have. You tested the current limit on the power supply and whatever cap it has on the output was discharged through your meter. Worst case, it might be reading inaccurately on the current range. Most likely it is fine. \$\endgroup\$ Jul 12, 2015 at 17:29
  • \$\begingroup\$ @IgnacioVazquez-Abrams I had a look through the manual and I can't find any reference to burden voltage. I did a quick Google search and I couldn't make any sense of what I found. Could this burden voltage go by another name in the manual? What exactly is burden voltage? \$\endgroup\$
    – jren207
    Jul 12, 2015 at 19:07
  • \$\begingroup\$ On balance I'd say with a Fluke chances are very good it'll still be well within tolerance, usually they are designed for twice the manhandling that their fuses are rated for. It may depend a teeeeenssy bit on whether "expensive Fluke" is $80 range Fluke, or $800 range Fluke. A company or freelancer like me would not call anything below $250 expensive, but the hobbyist I used to be would call anything above $40 expensive. Then again, most $500+ Flukes would beep about your leads being connected wrongly. \$\endgroup\$
    – Asmyldof
    Jul 12, 2015 at 21:20

1 Answer 1


Your meter is most probably not broken. Check for an internal fuse, usually conspicuously placed and replace it with a similar fuse with a rating no higher than the original. Also, if your power supply is not working, check that for a blown output fuse. Good luck!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.