0
\$\begingroup\$

I'm trying to draw a circuit diagram using Eagle CAD (v 6.5...), but one of the parts that I want to use isn't coming up in the component library. I know the diagram for the component is available since when I click "open" on the related library and browse to it it's there and I'm able to open and edit the part.

Does anyone have any advice as to why I can't browse to this part from "Add", and how to get the part?

It's an INA101HP (the part that's available is INA101_G, which has a close enough symbol for my purposes), which is in the Burr-Brown library (although if I expand the dropdown to look at the contents of the library the part isn't there....)

Screenshot

\$\endgroup\$
  • \$\begingroup\$ Can you add the folder in the Control Panel - on the eagle control panel screen (window 1), go to Options->Directories, then in the Libraries box add a ; after the current contents and add in the directory of the library. Can you see it now? \$\endgroup\$ – Tom Carpenter Jul 16 '15 at 12:26
  • \$\begingroup\$ Nope - unfortunately nothing happens. It took a few seconds to update the libraries and froze the program, but it didn't add the part. Thanks for the suggestion though \$\endgroup\$ – Callum.Flint Jul 16 '15 at 12:33
  • \$\begingroup\$ Do you have the file permissions set correctly on the folder the library file is in? If you put the library somewhere like the project folder (or in fact anywhere you have read/write access to) then @Angs answer should allow you to use it. \$\endgroup\$ – Tom Carpenter Jul 16 '15 at 12:35
  • \$\begingroup\$ The symbol I want to use is saved within Burr-Brown.lbr which is in the library folder within program files with all the rest of the libraries I'm currently using. I don't know if there are other symbols that it's not letting me see, but it's letting me see hundreds of other symbols/components \$\endgroup\$ – Callum.Flint Jul 16 '15 at 12:47
  • \$\begingroup\$ @Callum.Flint After clicking Library-->Use...-->(Your library), go to Library-->Update All \$\endgroup\$ – DerStrom8 Jul 16 '15 at 14:30
1
\$\begingroup\$

@Angs @Tom Carpenter - So it seems that the device was never made - I had a symbol which had been procured from somewhere, but it wasn't linked to a package and wasn't a device in the library (hence why it never came up). So I've made the part and it now appears in the library. Thanks for all your suggestions and time - they are things I will definitely keep in mind when I'm using this software

\$\endgroup\$
0
\$\begingroup\$

You need to add a new component to the list via

Library > Use > (browse) xxx.lbr

enter image description here

Then you will be able to see the part on add

\$\endgroup\$
  • \$\begingroup\$ Unfortunately that doesn't work - I don't have the option of browsing to a library. When I look at the list of available libraries I can right click on, and select to use a library, but I can't browse to anything, it's more of a toggle feature \$\endgroup\$ – Callum.Flint Jul 16 '15 at 12:08
  • \$\begingroup\$ Can you put a print screen what you get when you press Library > use on the menu? \$\endgroup\$ – Angs Jul 16 '15 at 12:24
  • \$\begingroup\$ Not really... If you mean on the toolbar - Library isn't there, if you mean right clicking on the Library dropdown and then clicking use what changes is the colour of an indicator (it goes green to show that the library is being used)... \$\endgroup\$ – Callum.Flint Jul 16 '15 at 12:27
  • \$\begingroup\$ I added a printscreen, if you don't have it. Go to the main eagle window (not .sch nor .brd), then Options > User Interface, then select all "Controls" options \$\endgroup\$ – Angs Jul 16 '15 at 12:31
  • \$\begingroup\$ They're all already selected. That looks like a newer version - in my original post I mentioned I'm using v6.5...? \$\endgroup\$ – Callum.Flint Jul 16 '15 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.