0
\$\begingroup\$

Below is a cutout of the schematic and close up PCB for a detector I've asked several questions about. Specifically pin 6 on U3, R23, and R21.

I've measured voltages higher than 7.5 from pin 5, which should make the output to pin 7 go HIGH. Instead, it stays low. But once I touch the bottom side of R23, R21, or Pin 6, with the oscilloscope pin the signal goes HIGH (IE I get an output from pin 7).

Does this mean there's a cold solder joint somewhere on these 3 pins? I'm having this issue with several other PCB and would seem odd that every one has a bad solder joint here.

Schematic Pins

\$\endgroup\$
  • \$\begingroup\$ Does it only happen when you touch it with the scope probe? Or can you reproduce it by touching the pin with something else, like with something plastic (e.g. bottom of a pen)? Also, is C6 polarized? \$\endgroup\$ – DigitalNinja Jul 28 '15 at 23:39
  • \$\begingroup\$ Only the probe. Doesn't happen with screwdriver or pen. --- C6 is ceramic. \$\endgroup\$ – Luke Jul 28 '15 at 23:43
  • \$\begingroup\$ How do you measure/know the output is high? \$\endgroup\$ – Asmyldof Jul 28 '15 at 23:44
  • \$\begingroup\$ And that's with the probe's ground wire connected to a ground on your board? What I'm getting at, is if if doesn't correct the problem with any type of pressure then it's more than likely not a connection problem. Scope probes have a their own capacitance and resistance that can sometimes influence your circuit if not matched with the scope. \$\endgroup\$ – DigitalNinja Jul 28 '15 at 23:44
  • \$\begingroup\$ @Ninja, I have one probe to the PCB "-" and the other measuring on Pin 6 or the resistors. \$\endgroup\$ – Luke Jul 28 '15 at 23:49
2
\$\begingroup\$

What voltage do you measure on pin 6? You should see about 7.5V. If you don't then I agree that it seems peculiar.

If pin 6 was open it would give those symptoms. The LM358 has PNP inputs so when open they will float close to the positive rail. They only have ~20nA bias current so the 10megohm scope probe will drag it down to ground and lower than pin 5 so giving your high output.

It seems unlikely though that there would be multiple boards with the same bad solder joint.

\$\endgroup\$
  • \$\begingroup\$ I measured 7.5V with a voltmeter. \$\endgroup\$ – Luke Jul 28 '15 at 23:53
  • \$\begingroup\$ The odd part is that this is happening to two completely different runs of boards (older), but not our most recent run. \$\endgroup\$ – Luke Jul 28 '15 at 23:57
  • \$\begingroup\$ I see. So what you're saying is when I touch Pin 6 with the oscilloscope, it's causing the pin to "go to ground", and pulling the op amp up (comparator is input VS 0V, so the input checks out). Right? \$\endgroup\$ – Luke Jul 29 '15 at 0:02
  • \$\begingroup\$ The fact that you can measure 7.5V with a voltmeter refutes that possibility. It also implies that there is not a bad joint or you would not measure 7.5V. Putting a scope probe to pin 6 will cause a brief pulse as the scope gets charged up. it is not obvious why that would affect things though. \$\endgroup\$ – Kevin White Jul 29 '15 at 0:12
  • \$\begingroup\$ Very good observation! Definitely something I've been checking into. Please see my comment above. \$\endgroup\$ – Luke Jul 29 '15 at 0:18
1
\$\begingroup\$

You say you have 7.75V on the input number 5.

That's 250mV above the 7.5V, which should be enough. But for a silly case where the voltage can be off a little.

If your supply is off by 10.3% (15.5V), the half-supply with perfect 0% resistors will be 7.75V.

If one of the resistors is off, or just mis-picked from a 90k batch, your center setpoint will be off enough. It puts you in a whole new realm of debugging. And I'll tell you for why:

If you have a scope probe set at 1x or a normal low budget digital multimeter the chances are good they are only 1MOhm. 1MOhm next to 100kOhm makes 91kOhm. Which is also off by a good 9%, dropping your V- on the second op-amp several hundred milivolt if you measure there with the 1M probe or DMM relative to GND/V-.

In the case of the scope-probe, you should really set it to "10x", since that will make it 10MOhm total, which reduces effect of the parasitic resistance your schematic will see. If you already had that, well I could just be dead wrong.

Point is, every measurement device has an internal resistance, for a voltage measurement device it's high, but not infinite. My best Multimeter still has 100MOhm as maximum setting, and that's a very very high-end one and measuring something will have you put that resistor in parallel.

Another option is that you connect the ground clip to a wrong terminal by accident, shorting a signal to ground. Remember that your oscilloscope is hard-connected to power earth in most cases, and so might your board's GND or V- be. You need to be sure about which it is before you clip on the probe's ground. A digital multimeter that's battery powered will be floating and you can then put either probe anywhere and you will only have the internal resistance to think about (if not known, assume 1MOhm for cheap, 10MOhm for mid range, more than 10M if you've burnt some serious cash on it ;-) )

That's about all I can think of to look for in the debugging process with the information currently available, just before I move towards my bed.

\$\endgroup\$
  • \$\begingroup\$ To your first section, yes I 100% agree and that's why I'm having an issue. It should be above the threshold but it's not. To the second half, I changed the scope probe to x10 and it fixed the "touching issue". So question answered I guess. \$\endgroup\$ – Luke Jul 29 '15 at 15:37
  • \$\begingroup\$ @Luke in which case I wonder, with the 10x probe, do you also measure a voltage above 7.5V on the set-point pin? That would make the answer definitive. (Many/most/all digi-scopes have the option in the channel menu to set it to 10x probe and then the voltages displayed will be adjusted so they are correct again). \$\endgroup\$ – Asmyldof Jul 29 '15 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.