0
\$\begingroup\$

I am using a L6470H as step motor driver. The data sheet told me to use the following configuration for voltage pumping:

schematic

simulate this circuit – Schematic created using CircuitLab

(Value of C1 and C2 is not correct). I used a combined diode with 40V breakdown voltage, and 250 mA as forward current as D1 and D2 ((Datasheet)), after I assumed that the maximum voltage will be 2*12V. Nevertheless it burned on the first live test. What should be the maximum resistance of the diode? 48V? How can I calculate that?

Update: Apparently the problem was in the Driver, after VBOOT has a direct connection to GND, leading to 12V/20A max going through the diode array.

\$\endgroup\$
1
  • \$\begingroup\$ 40V/48V are not resistances of a diode. Are you talking about its breakdown voltage? You probably want to look for the diodes amp rating. \$\endgroup\$
    – PlasmaHH
    Commented Aug 14, 2015 at 10:33

1 Answer 1

1
\$\begingroup\$

The diode you used should be adequate. The BAT64 series come in several pinouts and it is not unheard-of for pin numbers to get mixed up on an SMT part footprint vs. schematic symbol.

Check directly with a multimeter on diode function that the pinout and wiring is what it should be.

\$\endgroup\$
5
  • \$\begingroup\$ The diode just smoked up, so measuring is out of question. But nevertheless the information about the diode is useful. Which else reasons could the failure have? \$\endgroup\$
    – arc_lupus
    Commented Aug 14, 2015 at 12:16
  • \$\begingroup\$ Faulty part(s) including the chip (unlikely) or a short (testing should detect it, perhaps even in your charred prototype). \$\endgroup\$ Commented Aug 14, 2015 at 12:20
  • \$\begingroup\$ You mean that a short circuit induced a too high current on the diode? \$\endgroup\$
    – arc_lupus
    Commented Aug 14, 2015 at 12:21
  • \$\begingroup\$ Sure- suppose the VBOOT pin was shorted to the grounded thermal pad under the chip- that would certainly do it. \$\endgroup\$ Commented Aug 14, 2015 at 13:24
  • \$\begingroup\$ It wasn't, the chip itself was faulty. \$\endgroup\$
    – arc_lupus
    Commented Aug 15, 2015 at 5:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.