0
\$\begingroup\$

I designed a custom board with stm32f373vb lqfp 100. I made the soldering from the 4-th attempt. It was easy, when you know the technique and have a microscope. Anyway I checked the pins with the microscope and there was indeed one problematic pin which was out of the pad and stacked between its pad and the pad of the next pin. With a pinset and the microscope I was able to smash it and make it very thin so that there was no visual connections.

problematic pins marked with the red circle

Then I tested the micro-controller with the JTAG and Ulink2. Interestingly it was not working before I placed the jumper within the Ulink2 to 3.3V, which for the previous prototype was not necessary as well as for another board with stm32f105. Then it worked perfectly. After that I was soldering other components responsible for display power supplying, among them one r2s-0515 dc converter, but it was still working, and suddenly after some time the uC became very hot and started to make a noise. I checked the supply voltage - 3.4 V, though previously was 3.31 V, then I checked with debugger - programming successful, still the processor hotter and hotter, and finally I checked for short circuit with the multimeter and boom. First I though this is very weird, the processor working, but VDD is grounded, and the voltage on the 3.3 regulator is 3.4!? I started to remove everything on the 3.3 V line, and all caps were O.K. the regulator itself was O.K.so this means that the uC is shortening somehow and somewhere the VDD? How is that possible? And what could be the reason for that? How to avoid it?

Here is the part of the schematic: enter image description here

Thanks!

\$\endgroup\$
  • \$\begingroup\$ Scrap the board and build another. It'll save a lot of time. \$\endgroup\$ – Leon Heller Aug 15 '15 at 19:13
  • \$\begingroup\$ If the uC gets hot then one possibility is that there is a solder bridge between one of the VDD pins of the uC and an adjacent pin which is configured as an ouput (and outputting 0V) so there is a shortcircuit inside the uC. \$\endgroup\$ – Roger C. Aug 15 '15 at 19:43
  • \$\begingroup\$ @RogerC. this is one possibility in general, but in this case the short circuit remains even when there is no power supply i.e. the whole board is powered off. Also I checked very carefully with the microscope I'm pretty sure that there are no bridges, and also it was working before without any short circuits. I changed the program on the uC. Could it be that some port is damaged and now stacks at 0? But how could that be? \$\endgroup\$ – judoka_acl Aug 15 '15 at 21:34
  • 1
    \$\begingroup\$ @LeonHeller I've run out of uC, because I've broken already 3 out of 4 during the soldering, till I've got the skill. So while I'm waiting for the next deliver I want to try to fix that, and the most important - learning from mistakes is bringing the experience! \$\endgroup\$ – judoka_acl Aug 15 '15 at 21:37
  • \$\begingroup\$ @lalamer, yes it is almost certain that some component in this uC is damaged; a common failure mode for a semiconductor that receives too much current is a shortcircuit. \$\endgroup\$ – Roger C. Aug 15 '15 at 23:39
0
\$\begingroup\$

Just for anyone that has experienced the same problem I'm posting the solution.

The problem was that the microcontroller was damaged in such a way that the protection diode of some port formed a short circuit between the power supply and the ground:

enter image description here

There were two reasons for that. The first and main reason was that I have unplugged the JTAG cable, while the PCB was switched on. I'm trying to figure out exactly how, but that action made some of the ports acting as a ground and damaging the protection diode to act as short circuit. So the conclusion is first power off then unplug the JTAG. The second reason was that the JTAG was supplied with 3.3V (VCC) from the debugger. For my previous boards JTAG supply was provided always by the PCB itself, but now for some reason it didn't worked out (though I'm measuring correct supply provided TO the JTAG) so I had to switch to the debugger power supply. I think that supplying from the debugger and at the same time from the board made a short the connection between a port and 3.3V supplied from the PCB and burned that diode.

Conclusions:

  1. avoid using the JTAG debugger supply (VCC) and
  2. avoid unplugging the JTAG cable, while PCB is powered on or
  3. use a dc/dc insulator for insulating the JTAG GND and VCC
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.