1
\$\begingroup\$

I am trying to use ESP8266(ESP01) by interfacing it with Arduino using USB power. I followed the given tutorial.

When I disconnect and reconnect ESP with Arduino it throws random symbols on the serial monitor and after doesn't responds to the AT commands. When I again disconnect and reconnect again some random symbols are thrown on the serial monitor. enter image description here

I tried different baud rates but the result is same. I also noticed that at some baud rates it is not giving the random symbols. Also, my ESP doesn't have an updated firmware and I am using AMS1117 power module to step down 5V and using it as an input for ESP.

Any suggestions for this problem?

\$\endgroup\$
  • 2
    \$\begingroup\$ "I tried different baud rates" - which ones? According to this tutorial the baud rate depends on the firmware version. Also, make sure you only change the ESP8266 baud rate, keep the Arduino Serial at 9600. \$\endgroup\$ – Roger Rowland Aug 18 '15 at 4:49
  • \$\begingroup\$ If you are using Arduino as isp, connect a wire between reset and ground on the arduino, and try different baud rate, use 3.3v for rx and tx and to power the module, make sure you connected the wires properly, and you are good to go \$\endgroup\$ – Piki Aug 9 '17 at 3:36
3
\$\begingroup\$

I had this problem as well. Trying all different firmware versions and baudrates I could find, finally helped. I don't remember which combination finally worked though, so you will have to do the same.

\$\endgroup\$
  • 1
    \$\begingroup\$ For me the baudrate is 57600 baud. \$\endgroup\$ – Akshay Mar 30 '17 at 16:28
2
\$\begingroup\$

I got the desired response from ESP01. I used the same set up but this time I used windows 7 OS and it worked. Previously, I was using Ubuntu 14.04. I am trying to figure out why it was not working in Ubuntu. I will update this answer once I get the reason. I am listing out the things that helped to get the desired output.

Firstly, I used ESP01 without the updated firmware. Arduino UNO for serial connection and DC/DC Step-Down Voltage Regulator 3.3 volt Power Supply Adapter AMS1117-3.3 V and a USB cable to power up the Arduino.

enter image description here

Baud rate was set to 115200 for ESP. On other baud rates I was getting a garbage response. I connected the Tx and Rx of ESP directly to Arduino without stepping down.

Check out the reference link for code and other details. References: http://allaboutee.com/2014/12/27/esp8266-arduino-code-and-circuit/

\$\endgroup\$
2
\$\begingroup\$

I have got a couple of these modules recently, and they worked fine on both Windows 7 and Xubuntu 12.04. Keep in mind its base baud rate is 115200 and CR+LF is required; as your picture shows, you were using 9600.

\$\endgroup\$
2
\$\begingroup\$

I was having this problem on my factory condition chip. I built the latest firmware using the NodeMCU Cloud Build Service and flashed it using NodeMCU Flasher.

Then I connected to NodeMCU using ESPlorer at baud rate 115200 and then hit the reset button on the chip. I got the following message on the console:

NodeMCU custom build by frightanic.com branch: master commit: b96e31477ca1e207aa1c0cdc334539b1f7d3a7f0 SSL: true modules: enduser_setup,file,gpio,http,net,node,ow,pwm,spi,tmr,uart,websocket,wifi,ws2801,ws2812,tls build built on: 2017-02-04 09:01 powered by Lua 5.1.4 on SDK 2.0.0(656edbf) lua: cannot open init.lua >

Then I sent it a test program which flashes the light on and off every second:

while 1 do gpio.write(0, gpio.HIGH) tmr.delay(1000000) -- wait 1,000,000 us = 1 second gpio.write(0, gpio.LOW) tmr.delay(1000000) -- wait 1,000,000 us = 1 second end

This seems to have worked. If anyone needs help setting it up, feel free to PM me.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.