0
\$\begingroup\$

I tried to measure some HDMI signals (the TMDS Clock) from my PS4 with a keysight MSOX3104A Oscilloscope. After my "measurement" the PS4 did not send any HDMI signal to the connected TV. Multiple soft resets (safe boot) did not fix the problem. I also tried another monitor to check on the signals, but same problem. Setup was a cut open HDMI cable with one end open and following connection to the oscilloscope:

  • GND from Oscilloscope to TMDS_CLOCK-
  • CH1 from Oscilloscope to TMDS_CLOCK+
  • Input impedance was 1MOhm.

Is it possible the oscilloscope damaged the HDMI port? And why does the PS4 not send a valid HDMI signal anymore?

I can't imagine how this happened because I think I did everything right:

  • The PS4 was isolated from earths ground.
  • The HDMI port should be short circuit safe according to the specifications.

Any ideas?

(If this is "off-topic", please let me know where I can ask this question..)

\$\endgroup\$
  • \$\begingroup\$ I tried to measure the clock speed of the HDMI Signal \$\endgroup\$ – d3L Aug 20 '15 at 18:59
  • 1
    \$\begingroup\$ GND on oscilloscope is tied to Earth Ground, CLK- is referneced to GND with some voltage depending on where in the clock cycle you are, you shorted CLK- to GND likely damaging it \$\endgroup\$ – crasic Aug 20 '15 at 19:05
  • 1
    \$\begingroup\$ Yes, but the ground loop on your probe is earth ground, so you coupled your PS4 to earth ground through the HDMI port, there are any number of ways this can damage components. \$\endgroup\$ – crasic Aug 20 '15 at 19:09
  • 2
    \$\begingroup\$ Next time it would be much safer to connect Probe GND to PS4/HDMI common, and measure CLK+ and CLK- seperately and subtract on the scope. There are also isolating transformers you can use to safely "float" the o-scope (or the dirty cut the ground prong trick that is not recommended) \$\endgroup\$ – crasic Aug 20 '15 at 19:09
  • 1
    \$\begingroup\$ "My plug has only 2 pins (Neutral and Phase)" - even worse than a short to ground :( the whole PS4 may have been floating at around 60 V AC, half the supply voltage. The capacitors in the filters will only pass a few hundred microAmps, but that may have been enough. \$\endgroup\$ – tomnexus Aug 20 '15 at 19:31
8
\$\begingroup\$

GND from Oscilloscope to TMDS_CLOCK-

This was almost certainly the cause of your problem.

TMDS Clock- is not a ground; it's one half of a differential pair! Connecting it to the ground on your oscilloscope shorted it to ground, which may have damaged the transmitter.

For future reference, you should have connected the ground of your oscilloscope to pin 11 (TMDS clock shield), or to the overall shield of the HDMI cable, to measure the behavior of one of the signals in the pair. Alternatively, to measure the differential signal, connect one probe to each signal in the pair and set your oscilloscope to measure the difference between the signals.

\$\endgroup\$
  • \$\begingroup\$ I know it's a differential signal, nevertheless the PS4 does not function proplery anymore and I don't know why. (As said, I think the GND from the PS4 is isolated) \$\endgroup\$ – d3L Aug 20 '15 at 19:05
  • 5
    \$\begingroup\$ even if its isolated, you just connected CLK- directly to ground, any stray voltages or charge built up over that isolation in the PS4 now has found a path to Earth through your osiclloscope probe and therefore through the clk out pin on the HDMI \$\endgroup\$ – crasic Aug 20 '15 at 19:07
  • \$\begingroup\$ So for example: the stray voltage you were talking about could be referenced to earths ground, right? So the charge has been built up in the insolation of the layer of the HDMI cabl. And then it could flow back into the HDMI port because I created a path from CLK- to earths ground. Is that what you are saying? \$\endgroup\$ – d3L Aug 20 '15 at 19:16
  • 1
    \$\begingroup\$ I am so glad I watched this EEVblog before I got my scope! eevblog.com/2012/05/18/… \$\endgroup\$ – BenG Aug 20 '15 at 19:48
  • \$\begingroup\$ @BenG Did watch it too. Here is a better explanation of what went wrong eevblog.com/forum/beginners/… \$\endgroup\$ – d3L Aug 23 '15 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.