1
\$\begingroup\$

I am trying to design 100W (100V - 1A) Opamp Current Buffer with unity voltage gain. I will use PA441 or LT6090 opamp.

Apex published a circuit for this amplifier. Please look at page 3 from the link below

https://apexanalog-public.sharepoint.com/Resources/AN52U.pdf

Shared circuit is for inverting amplifier configuration. I need non-inverting configuration. When I tried the circuit in LTSpice, for negative side, it seems works well. But for positive side there is a problem witn nmos i could not handle.

Circuit Schematic

enter image description here

How could I amplify 0 to 100V 100mA output to 0 to 100V 1A with non-inverting configuration?

I would be very glad if anybody could help. Thanks.

\$\endgroup\$
  • 1
    \$\begingroup\$ So, what is the problem you couldn't handle? \$\endgroup\$ – WhatRoughBeast Aug 23 '15 at 18:19
  • \$\begingroup\$ I could not add simulation result because of being newby =) but the problem is, positive voltage output of buffer could not exceed 14.5 V and 48mA \$\endgroup\$ – meakcey Aug 23 '15 at 18:29
  • \$\begingroup\$ Simulation result postimg.org/image/hkq6tojev \$\endgroup\$ – meakcey Aug 23 '15 at 18:38
  • \$\begingroup\$ When the output is 14.5, what is the PA341 output, and what is the voltage at the - input? Also, what is your vsig at this time? \$\endgroup\$ – WhatRoughBeast Aug 23 '15 at 19:26
  • \$\begingroup\$ I added all the related outputs to new image postimg.org/image/69jhsw59l V(sgn) blue one is input signal. This one is amplified with x11. V(n03) red one is PA341 output. V(n02) yellow one is the buffer output. IR12 is the buffer output current through 300 ohm resistor. \$\endgroup\$ – meakcey Aug 23 '15 at 19:37
3
\$\begingroup\$

At a guess, your PA341 is bad. Try disconnecting the buffer, and just close the loop with about a 10k load resistor.

EDIT - Since the PA341 is good, a closer look establishes your problem. The app note clearly requires a depletion-node FET, and you are using an enhancement-mode part. They do not work the same.

\$\endgroup\$
  • \$\begingroup\$ I attached PA341 non-inverting configuration result postimg.org/image/xl75a4du3 It seems working well \$\endgroup\$ – meakcey Aug 24 '15 at 10:41
  • \$\begingroup\$ @meakcey - See edit. \$\endgroup\$ – WhatRoughBeast Aug 24 '15 at 11:25
  • \$\begingroup\$ The problem was the exactly as you indicated. I've also asked to Apex Support and they replied with to change mosfet with depletion mode one IXTP6N50D2. Schematic is working now. Thanks for your reply. \$\endgroup\$ – meakcey Aug 24 '15 at 17:48
  • \$\begingroup\$ Good to come back and notice that FET was supposed to be depletion mode. \$\endgroup\$ – gsills Aug 27 '15 at 22:37
3
\$\begingroup\$

This circuit has problems.

It is doubtful that M1 ever becomes active. Vgs is clamped by D5 and D6 to about 1.4V, but needs to be over 4V to get over the Vth needed. So, M1 doesn't conduct, that also means no current for Q2. PA341 supplies buffer output current through D5 and D6, then through D1 and D2 until it hits current limit at ~48mA, as set by R4. After current limit takes over the output doesn't go any higher.

Also, Is it possible to still get PA341's? I thought they were discontinued.

\$\endgroup\$
  • \$\begingroup\$ hmmm, I will try your suggestions, thx \$\endgroup\$ – meakcey Aug 24 '15 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.