-1
\$\begingroup\$

I tried to send "AT" command via UART at some baudrate to my Cinterion BGS2T, and I am always getting response "ERROR".

I get error on every AT command.

How can I know what is wrong, or how to check on what baudrate module works now?

\$\endgroup\$
  • \$\begingroup\$ Who sends this response? What terminal program you have? \$\endgroup\$ – Marko Buršič Sep 10 '15 at 11:41
  • \$\begingroup\$ Beaglebone sends at command \$\endgroup\$ – Junior Sep 10 '15 at 11:43
  • \$\begingroup\$ First try with PC, terminal window. You can use Windows Hyperterminal for this, however I do use TeraTerm. Hook up the modem and PC (you will need USB to RS23 converter, if your comp does not have rs232). Then try with specified baudrate and settings like in the manual (115K 8N1) \$\endgroup\$ – Marko Buršič Sep 10 '15 at 11:57
  • \$\begingroup\$ BSG2T Autobauding, chapter 4.7.1, there are some restrictions like: "The serial interface shall be used with 8 data bits, no pa rity and 1 stop bit (factory setting), e.g. 2 stop bits are not supported for Autobaud mode. ". All of them are OK? \$\endgroup\$ – Bence Kaulics Sep 10 '15 at 12:11
  • \$\begingroup\$ Yes. @BenceKaulics \$\endgroup\$ – Junior Sep 10 '15 at 12:12
1
\$\begingroup\$

I found where is problem, in my code on Beaglebone I did not send appropriately formated AT command like "at\cr\lf" and GSM module received something that is not recognized and always returned ERROR.

Now everything works OK!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.