0
\$\begingroup\$

The LED is connected in between an NPN bjt and 2.4K Resistor at 30V A few of these tend to emit a small amount of light even when the transistor is off condition.

Vce (of glowing at off condition) is 28.15 wheras Vce (When LED is off when Transistor is off) is 28.55/28.60V

Nominal current for the LED is around 10mA.

If this is due to the transistor, what is the reason?

enter image description here

\$\endgroup\$
  • 3
    \$\begingroup\$ obviously the transistor is not off \$\endgroup\$ – PlasmaHH Sep 14 '15 at 14:57
  • \$\begingroup\$ Can you note the transistor you are using? \$\endgroup\$ – Funkyguy Sep 14 '15 at 15:07
  • \$\begingroup\$ BC107 is the transistor. How can a LED glow with such a low current \$\endgroup\$ – user1589759 Sep 14 '15 at 15:11
  • \$\begingroup\$ @KarthikShetty An LED will glow with <1mA, although it may not be visible. All it needs is to have the voltage across the LED exceed its forward voltage for the amount of current you present it (usually about 1.9V for red and ~2-3V for green and blue). Your 30V + 2.4K resistor + BJT could easily do that since your transistor isn't off (if it were, VCE would be straight up 30V since IC would be 0 and the voltage across the resistor would then be 0, giving you 30V on VCE). \$\endgroup\$ – Los Frijoles Sep 14 '15 at 15:15
  • 1
    \$\begingroup\$ @KarthikShetty You missed the important spot. Where is this wire connected to D1 and R23 going to? \$\endgroup\$ – Alexxx Sep 14 '15 at 16:03
1
\$\begingroup\$

Since the base voltage is only 80mV, it pretty much has to be the transistor. If..if..if the base voltage is steady and not spiking up to a few hundred mV or more every once in a while. If that is happening, an oscilloscope should be able to catch it.

The specification at room temperature is for 15nA leakage maximum, and no more than 10uA at 150°C. I presume you would have mentioned if the transistor was that hot. 15nA is not enough to light an LED visibly. 15uA might be (a very efficient LED in a dimly lit room).

enter image description here

To be absolutely sure, remove R23. If the LED remains on then transistor leakage (or severe PCB leakage) is your problem.

\$\endgroup\$
  • \$\begingroup\$ I have had problems in real designs where 10 uA caused a faint glow in a red LED. Red LED's seem to be the worst in this regard. In my case, I fixed it by adding a 10k resistor in parallel with the LED. \$\endgroup\$ – mkeith Sep 14 '15 at 18:45
  • \$\begingroup\$ @mkeith True enough, but if it's leaking 10uA it's either defective or almost 150°C. In the former case, I'd suggest throwing it in the garbage bin since it's so contaminated it will probably fail soon anyway. And a good transistor is 0.5-2 cents. \$\endgroup\$ – Spehro Pefhany Sep 14 '15 at 18:51
  • \$\begingroup\$ agreed. In my case, I knew exactly why the current was flowing, and the amount of current flow was predictable and bounded. But I agree with your answer above 100%. First confirm that the transistor is leaking, then go from there. \$\endgroup\$ – mkeith Sep 14 '15 at 18:57
  • \$\begingroup\$ The problem exists even when the Transistor is pulled down to -15V by removing R23 and i've observed that the rise in Vce is exponential and takes around a minute or so. Could this be due to some parasitic capacitance across collectr and emitter or is the whole batch of transistors is bad? \$\endgroup\$ – user1589759 Sep 17 '15 at 13:09
  • \$\begingroup\$ Sounds like the transistors are bad (leaky). Try heating it with a heat gun. \$\endgroup\$ – Spehro Pefhany Sep 17 '15 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.