2
\$\begingroup\$

I'm rather new to electronics but I have a fundamental grasp of the general concepts. I'm not very fluent, however, on the workings of specific devices as of yet (internally, I mean; inside their little brains).

I bought several cheap but amazingly good USB Bluetooth music receivers for several music outputs at home. Obviously, I had thought about the issue with having them all named the same and not being able to tell which is which upon trying to connect to a specific one. But I guessed that I would be able to solve that later in a simple way. I since realized that manufacturers give no option of this, even when the names of their apparatii are so little allusive such as H-163 or PT-810! And searching online I have only found two threads that ask this question (amazing!); one has the sole response: "NO, impossible" (which I always tend to question as a response); the other links to this explanation:

Bluetooth configuration

So I went online and bought me a USB To TTL Serial Converter:

USB to serial converter

According to this set of instructions, all that's needed is the serial converter connected to the computer. Not the Arduino. Although I think there probably is a way of going about this through the Arduino. Anyway, I disconnected my Arduino and proceeded to connect everything as you see in the photos (and as is instructed in the link above).

enter image description here enter image description here

VCC on the BT receiver is connected to VCC on the serial converter. GND to GND. TX is connected to RX. RX is connected to TX. As per instructions.

Now, everything should be working according to what I've read in the above link. As you can see, at least both devices are receiving power and the serial converter is being recognized by my computer and by the Arduino EDI as being connected to a port. As it does seem like the above instructions are talking about a normal BT receiver, this should be a cinch; however, when I go through the AT test in the Arduino EDI Serial Monitor, I get no response. I've tried with all available Baudrates. I've tried switching the RX-TX cables to see if I had got the wiring wrong. I've also tried moving my connections up and down the breadboard just in case there was a dead row. Nothing: is the final answer.

At this point I've no clear idea as to what may be going wrong. Is my serial converter not working properly? How could I test this? Do these BT receivers have no real RX-TX connections? It seems they do, as I've already vivisected one, you can see it here:

enter image description here (Yes, I have also tried connecting this franken-BT-receiver; as well as two other receivers and still no response. And yes, I did muck up the audio output on this one: my soldering wick was out and I tried desoldering the audio jack the brutish way and what I did was strip off the copper paths! I had to somehow undo this muck-job and this ugly beast is the result. Although I assure you it works 100%! It's the best receiver in my arsenal!)

And, therefore, it stands to reason that these are working RX-TX connections. This last again is evidence to me that configuration of these little devices should be possible, as in practice the USB port is only used to draw power, as there is no data transfer involved (these things work on a computer's USB port just as they work connected to a USB to power-plug adapter), so it only makes sense the manufacturer would hook up the RX-TX terminals in order to be able to communicate config. date from and to the device once it is fully built.

So I'm wondering what I'm doing wrong. Or if perhaps there's another way of changing the name on these devices. I'm sure there HAS to be a way of doing this. I'm amazed more people don't want to do it. But, anyhow, I'm glad to add another thread on this issue out there, because I'm sure at least someone else is or will probably want to do this at some point. And if I can get a positive answer on this, then now there'll be a source for everyone to find an answer to this question.

I thank you all in advance for your input! I'm sure it will be very useful and will help me understand these devices a little more!

\$\endgroup\$

closed as off-topic by Chris Stratton, Edgar Brown, Finbarr, Dwayne Reid, Elliot Alderson Dec 24 '18 at 14:49

  • This question does not appear to be about electronics design within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    \$\begingroup\$ Those are some NASTY solders. \$\endgroup\$ – Scott Seidman Sep 18 '15 at 15:04
  • \$\begingroup\$ @JRE, thank you very much for the edit that has allowed my post to look like I originally intended! \$\endgroup\$ – QuestionerNo27 Sep 18 '15 at 15:05
  • \$\begingroup\$ I figured if I couldn't help with the real problem, I could at least fix the links. :) \$\endgroup\$ – JRE Sep 18 '15 at 15:07
  • \$\begingroup\$ @ScottSeidman, indeed they are! I'm not at all proud of them. But believe me it was the only way I managed to bring the device back from the dead. Inside each there's a metal lead that drills straight through to the components on the other side! It's really a miracle the thing still works. \$\endgroup\$ – QuestionerNo27 Sep 18 '15 at 15:11
  • 4
    \$\begingroup\$ I'm voting to close this abandoned three year old question as off-topic because no information to indicate if the goal is even possible or how the attempt is failing has ever been provided. Thus this is never likely to be able to be resolved. \$\endgroup\$ – Chris Stratton Dec 21 '18 at 19:04
0
\$\begingroup\$

After looking at your pictures and checking the USB/Serial converter supplier's site, I would say it looks like you have the serial converter set to 5Volt TTL levels.

I expect you bluetooth module uses 3.3Volt levels.

There's a jumper down by the connector that goes to the breadboard. From its position, I'd say it is set to 5V. Disconnect power and move the jumper to 3.3V (to the right) and see if it works.

\$\endgroup\$
  • \$\begingroup\$ thanks a lot for your answer. I had thought of this at some point but discarded the idea because I assumed the USB BT receiver would no doubt pull 5V. So I didn't test it. I have now that you mentioned it but unfortunately I continue getting no answer from the BT devices. (I continue searching online but can't find anything anywhere.) \$\endgroup\$ – QuestionerNo27 Sep 18 '15 at 22:06
  • \$\begingroup\$ USB Power is 5V, but USB data is 3.3V. Some devices just bring the power down to 3.3V with a simple zener diode, not even using 5V directly. You may have fried the IC trying to use 5V on data lines. \$\endgroup\$ – Passerby Jul 18 '16 at 6:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.