5
\$\begingroup\$

I am new to the whole Arduino thing and am having problems loading 'Processing'.

When I attempt to run the Processing program it says 'This Program requires Java Development Kit 1.5.0'. When I go the the Sun site to load this, I can't find SDK 1.5.0.

Does anyone know the exact name of the app I have to load in order to successfully run Processing? A web link to the correct app would be greatly appreciated.

\$\endgroup\$
1
  • \$\begingroup\$ What operating system do you use? Windows or Mac? \$\endgroup\$ – Toby Jaffey Mar 16 '10 at 23:05
5
\$\begingroup\$

You need the sun JDK 1.5 or above (current is 1.6) there http://java.sun.com/javase/downloads/index.jsp you may need the JRE too, I can't remember if it's included with the JDK.

If you're on linux then it's easier to use your distributions own packaging system to install.

\$\endgroup\$
2
\$\begingroup\$

You want "Java for your Desktop", as they call it on the Java.com homepage. The easiest way to get that is to go to Java.com's "Free Java Download" page: http://java.com/en/download/

Just accept all the defaults (but probably uncheck installing the Yahoo toolbar), and in a few minutes you'll have Java on your system.

(btw, you don't need Processing to use Arduino)

\$\endgroup\$
2
\$\begingroup\$

Go to http://www.java.com/getjava/ and follow the download link.

\$\endgroup\$
1
  • \$\begingroup\$ Thanks very much to chemicaloliver, todbot and Joby Taffey for your responses. Strange.....works fine on one laptop but not the other. Mystery??? Thanks to everyone. John \$\endgroup\$ – John Mar 18 '10 at 2:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy