10
\$\begingroup\$

I'm just starting to work with KiCAD. One of the video tutorial shows that 3D view should incorporate components placed on the board:

enter image description here

However in my case I can see only the board with pads:

enter image description here

Looks like I need to tune up my KiCAD installation (I'm using Windows 7, KiCAD version 4.0.0).

Could anyone give me any advize for that?

EDIT 1

As @Robert Stiffler mentioned I verified if the component 3D view is enabled. As I can treat the follwoing screen - everything should be OK. However the option name is differ from suggested ("Show component 3D shape" VS "Show 3D footprints"). So it is possible that I picked the wrong setting.

And the libraries are mostly standard.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ You will need to create 3D models, or find pre-made ones (perhaps from 3DContentCentral.com) and attach them to the footprints you're using. I haven't used KiCAD much (never cared much for it) but that's how it works in Eagle and Altium. \$\endgroup\$ – DerStrom8 Sep 23 '15 at 14:44
  • \$\begingroup\$ Few of the components have 3D models so far, however the SMD capacitors should be present. \$\endgroup\$ – Simon Richter Sep 23 '15 at 15:58
  • \$\begingroup\$ Common problem is missing path to 3D directory corresponding to relative path assigned to module. Double check also module property if 3D is really defined there. As last chance try a low level tool (SysInternals, strace or so) to see what WRL is being read. \$\endgroup\$ – TMa Sep 28 '15 at 18:30
  • \$\begingroup\$ Also be sure that you have "Show 3D Models" enabled in Preferences menu of 3D Viewer. \$\endgroup\$ – Michal Oct 23 '15 at 17:03
10
\$\begingroup\$

I solved this issue doing this:

  • Run Eeschema
  • Open CvPcb to associate components and footprints
  • Open Preferences -> Configure Paths
  • On "KISYS3DMOD" change the path to the correct one. "C:\Program Files\KiCad\share\kicad\modules\packages3d" in my case.
  • Restart the program.
  • Enjoy!
\$\endgroup\$
2
\$\begingroup\$

If you're on a Mac, the KISYS3DMOD path variable needs to be changed to: /Library/Application Support/kicad/packages3d. As installed, it had modules/ in between kicad/ and packages3d, but the modules directory doesn't exist in the OS X installation, at least on my version, 2015-10-10 BZR 6258.

Note that only footprints having 3D models will appear, as mentioned in another answer.

\$\endgroup\$
1
\$\begingroup\$

In the 3D view window, ensure that"Show 3D footprints" is enabled. You will also need to make sure that the components you are using have 3D models available. Most of the standard packages that come in the library have 3D models. If you created your own footprints or components, these won't have 3D models.

\$\endgroup\$
  • \$\begingroup\$ Thanks for your input! Please see EDIT 1 in the original question. I've added some clarifications. \$\endgroup\$ – Roman Matveev Oct 25 '15 at 18:24
1
\$\begingroup\$

On Ubuntu 14.04 the correct path is:

/usr/share/kicad/modules/packages3d
\$\endgroup\$
1
\$\begingroup\$

For Fedora 29 I had to install a separate package: $ sudo dnf install kicad-packages3d

\$\endgroup\$
0
\$\begingroup\$

This problem seems to be resolved for more recent versions of KiCad. I did however run into the same symptoms but different cause with KiCad 5, which I'm posting here for any wanderers who find this thread looking for the solution.

Basically if you have run KiCad 4 on your computer and then installed KiCad 5, the libraries are messed up. A full solution is discussed here. It boils down to going to

KiCad -> Preferences -> Manage Footprint Libraries

Then deleting all of the KiCad default libraries (which should be GitHub for ver 4) and re adding them from ${KISYSMOD} which varies by OS, but for macOS was

/Library/Application Support/kicad/modules/

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.