26
\$\begingroup\$

The following simple circuit gives the following error message when running ERC check:

ErrType(3): Pin connected to some others pins but no pin to drive it
@ (2.5000 ",4.0000 "): Cmp #PWR01, Pin 1 (power_in) not driven (Net 5) 

schema

The CONN_2 component is supposed to receive external power. I have not made any changes to any pin configuration of it which I probably should. How do I correctly do that?

\$\endgroup\$
16
\$\begingroup\$

I think the power flag is preferred and is what I usually use (and what the documentation recommends IIRC) to stop ERC errors if pins are not set to power output (see below) In the above you just need to put a power flag on pin 2 of the fuse and the warning should go away.

Also, you can set a component pin to a power (i.e. GND/VCC) output and no power flag will be needed.
Notice the 6V net does not have the same warning, I think as the opamp output will be set to an output.

Edit - just confirmed this works fine, so if you have e.g. a battery symbol then set the pins to power output and there is no need for flags. With a typical linear voltage regulator you would set the OUT pin to power output. This is common in all PCB software I have used, you need to make sure you set the pins to the correct type (not just power) when creating a component so the ERC can work properly. Here are the types available in Kicad:

PinTypes

The error only occurs (correctly) if a net has nothing to drive it, so if you have something like a power connector which has passive pins (if set correctly) it won't know they are intended for power until you tell it explicitly.

You can actually decide what you want to be told about, bu setting the table below accordingly. For instance if you wanted the ERC to throw an error if an input was connected to an input you would change the topmost box from green (no message) to yellow (warning) or red (error)

ERCOptions

\$\endgroup\$
  • \$\begingroup\$ Setting power output on the fuse pin 2 did solve the issue. \$\endgroup\$ – hlovdal Sep 11 '11 at 2:01
  • \$\begingroup\$ Thanks.That's exactly i was looking for. Goto Tools -> Library Editor Open your component in library editor.Press 'E' over component.Choose pin to edit.Change the 'electrical type' power output. Thats it. :) \$\endgroup\$ – user6919 Dec 7 '11 at 7:23
  • 16
    \$\begingroup\$ For folks who want tl;dr: The proper way to resolve the issue IS using (multiple) power flag(s) (symbol from "power" library, diamond-shaped, PWR_FLAG in the picture along the question), NOT editing symbol pins in library (especially if symbol is in standard library). \$\endgroup\$ – pfalcon Jun 14 '13 at 22:35
  • 1
    \$\begingroup\$ The following document helped me to resolve the issue in my case: blog.iteadstudio.com/wp-content/uploads/2014/09/… (Step 41). \$\endgroup\$ – dubbaluga Dec 25 '14 at 8:29
  • \$\begingroup\$ kicad often changes the way it works. heavy for beginners like me who only use it once a year. i tried the steps above, but i cant reoslve it. using a very very simply layout, vcc - switch - r - led - gnd gives headache! isnt there a simply working way to do very commin things without having to know all that magic? why must a simple switch input be changed to power out? i dont get it, its power-input for me. ;) \$\endgroup\$ – user68895 Mar 1 '15 at 11:33
0
\$\begingroup\$

In KiCad Schematic, if you connect a pin which is defined as Input , to another pin which was defined as input , and there is not third wire providing any voltage / current / signal input , its a logical contradiction. Isnt it ? This is what exactly "No Driven Means" To get rid of the error , change any of two pin type to output and it should be all right then...

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.