3
\$\begingroup\$

I'm looking for guidance on establishing a connection to an AVRISP mkII programmer via OS X.

Parallels Desktop 7 for Mac Build 7.0 14920 Windows 7 64-bit AVR Studio 4.19 730

After AVR Studio is installed I plug in the USB for the AVRISP mkII, it appears to detect the driver, then I attempt to connect from AVR Studio: Tools -> Program AVR -> Connect...

Then In the Select AVR Programmer dialog: Platform: AVRISP mkII Port: USB

After a few seconds I get a "Connect failed - Select AVR Programmer" message in that dialog.

When I check the Device Manager, under Jungo I see only AVRISP mkII (expected is to see both this and WinDriver). The AVRISP mkII shows an error like: This device cannot start. (Code 10)

I also tried an XP install via BootCamp - both the Win driver and AVRISP mkII drivers appeared in the device manager, and there was no Code 10 error, but I still received the "Connect failed" message on connect attempts from AVR Studio.

\$\endgroup\$
  • \$\begingroup\$ I tried with VMWare fusion w/o success either. Surprised about Boot Camp not working, I didn't have enough disk space to bother, so I moved to a PC. :) \$\endgroup\$ – kenny Sep 15 '11 at 22:07
1
\$\begingroup\$

It sounds like you need the TTY chip driver, or you need to associate the USB device's Vendor and Product ID to said driver. That programmer should manifest itself to the OS as a USB Serial Adapter.

Under windows, find the device in the device manager, and go to it's properties. Find the Hardware IDs in the tabs, and add them in here, then we can try to point you to the right driver for the programmer.

\$\endgroup\$
  • 1
    \$\begingroup\$ Thanks dreath, here are the hardware IDs: USB\VID_03EB&PID_2104&REV_0100 USB\VID_03EB&PID_2104 \$\endgroup\$ – Matt Andersen Sep 17 '11 at 0:15
  • 1
    \$\begingroup\$ Hmm. It's got the standard IDs: usb-ids.gowdy.us/read/UD/03eb/2104 In other words, it should "just work" \$\endgroup\$ – draeath Sep 19 '11 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.