3
\$\begingroup\$

I am a newbie in Eagle and I'm making a RF layout using GCPW. In the figure below, the pad and the track are in contact. However, the connection still unrouted, why? enter image description here

It became routed only when the track overpass the pad, but I cannot allow this condition.

enter image description here

Thanks in advance.

\$\endgroup\$
2
\$\begingroup\$

There are three options.

Option 1

This is as suggested by @CL, and is the simplest option. Basically you route your large trace as close as you can without it sticking beyond the end of the pad, then use a narrower trace to complete the connection. This is shown in the image below. I've highlighted the narrow trace so you can see it better.

narrow trace

Option 2

The next option is to complete the connection with a small polygon. This allows you to control the shape at the connection, but can be a bit of a pain. Again this is shown below. In the first image the settings I used are shown. In the second image the polygon is highlighted to give an idea of where I drew it. You need to make sure it extends over the centre of the pad, and also a small way beyond the end of the trace to ensure Eagle sees the connection.

Polygon settings

Polygon Highlighted

Option 3

The third option is the nicest as it ensures the trace width is maintained right up into the pad but makes sure it doesn't go beyond the end. This one takes a few steps to draw, but is relatively simple.

  1. Start by drawing a trace from the pad in the wrong direction (away from the wire coming in. The trace should extend so that the end point is at the edge of the pad and should be the same width as the trace you want to connect - don't worry that it curves beyond the pad at the moment. You can draw the trace then make the length of it equal to half the size of the pad.

  2. As is shown in the first image below, set the curve option to be 0.1 degrees (the smallest possible) and then click Apply (not Ok).

  3. Then set the cap option to be flat. You will notice that suddenly it looks like a rectangle as pictured. The curve is so small that it isn't really noticeable.

  4. route from the end of the new trace to your incoming trace with a thinner wire (you need to make it thinner to avoid the incoming trace and the new route from merging in to each other.

  5. Open the properties of this route. As with the other trace, set the curve setting to 0.1 degrees, again click Apply.

  6. Finally set the cap option to flat and the width setting to match the width of the incoming trace. Click ok and you should see something like is pictured in the second picture below. The third picture show the complete resistor once both sides are done in the same way. The fourth picture shows what the Gerber output looks like.

Third option first wire

Third option completed cap

Third option finished

Third option gerber

\$\endgroup\$
1
\$\begingroup\$

To connect a track to a pad, the end point of the track must be exactly on the pad's connection point.

Your problem is that the track's width is much larger than the pad. To connect the track without having copper beyond the pad, draw a short section of track with a smaller width.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.