4
\$\begingroup\$

I am facing an annoying problem while using Eagle in Linux. It is not possible to set the desired position of a component while ALT key is pressed. I hit the ALT key to active the alternate grid and then specify more precisely the correct position. I also tried to move the component while ALT is pressed, then release the key and left-click to set the position, but then the component moves to the main grid automatically.

I know there is other ways to solve this tricky bug during component placement, but it would be easier using this shortcut. Does someone have already faced this bug?

Thanks,
(I am using Linux Mint with Cinnamon.)

\$\endgroup\$
  • \$\begingroup\$ This question is better suited for eagle support, mailing list, or bug report \$\endgroup\$ – crasic Oct 28 '15 at 19:59
  • \$\begingroup\$ Are you clicking with the ALT button pressed? Or are you locating it with the ALT button and then release it and then click it. Because it needs to be set on the alternate grid before adjusting it on that alternate grid. \$\endgroup\$ – Weaverworm Oct 29 '15 at 15:29
  • \$\begingroup\$ I've tried both, @Weaverworm. \$\endgroup\$ – viniciuslb Nov 2 '15 at 23:31
1
\$\begingroup\$

EAGLE interferes with your operating system settings. I'm using OpenSuse with KDE5 Plasma, where ALT + mouseclick resizes or moves the window. EAGLE may notice the ALT key is pressed, but a click is intercepted by Linux.

Just try to remove the ALT + mouseclick key binding. As every linux differs a little, I can't tell you how exactly to do it. For me, it's in workspace settings / window behaviour.

\$\endgroup\$
1
\$\begingroup\$

In KDE Plasma 5 it can be disabled by:

System settings -> Window management -> Window behavior -> Windows Actions

You can change the modifier key or disable the left button action.

\$\endgroup\$
0
\$\begingroup\$

The solution that worked for me in order to solve this bug in Linux Mint with Cinnamon:

System Settings>Windows>Moving and Resizing Windows> "Special keys to move and resize windows: Disabled"

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.