2
\$\begingroup\$

I am getting the 'no driver IC on net' problem in Hyperlynx signal integrity software. Does anyone have any idea bout it? This is my PCB: enter image description here

It has an SMD connector and an AD9767 DAC. I have added the IBIs model to the pins of the DAC. Then I added stimulus to the pin of the connector on the net I want to simulate like this: enter image description here

After saving this, I tried to run the simulation on the oscilloscope but I get a mistake like this: enter image description here

Also i'm not able to add SLM (single line model) for the connector in BoardSim but the net can be exported to LineSim where transmission lines can be added to trace and described as a connector where SLM models can be added like this: enter image description here

But even after doing this I dont get simulations on the oscilloscope. I get the same error there too. What am I doing wrong?

\$\endgroup\$
  • \$\begingroup\$ Don't you need to have a model for the other end of the net, in your case the connector? I think there's something in Hyperlynx about doing off board nets - obd model or something? \$\endgroup\$ – Puffafish Nov 9 '15 at 14:13
  • \$\begingroup\$ Can someone also tell me how to add terminators to multiboard projects since the option seems disabled for a multiboard project. \$\endgroup\$ – Xavier Gonsalves Nov 15 '15 at 10:55
1
\$\begingroup\$

Hyperlynx defaults the model on a bidirectional pin to input and this is very probably the issue you are having.

Selecting 'models' will allow you to select the driver rather than the receiver.

Having selected the net, go to 'Models' -> Assign models / values by net.

Of course, you will need a model at each end of the net, as noted in a comment.

This will bring up a dialogue Model selector dialogue

Select each end of the link and ensure one of them is set to be a driver. I have not uploaded the next screenshot as my connection appears to be poor, but all you do is select the 'Output' radio button and you are set to go.

\$\endgroup\$
  • \$\begingroup\$ Thank you for your answer but can you direct me on how to add SLM models and MLM models to a connector in BoardSim. Hyperlynx allows to add SLM in LineSim but there is no help about MLM (multi-line model) in it. How do I add MLM model to a connector? Also can we add SLM to a connector in BoardSim. \$\endgroup\$ – Xavier Gonsalves Nov 10 '15 at 7:34
  • \$\begingroup\$ I will be in Hyperlynx later this morning, and I need to add models to a connector as it happens, so I will record it when I am doing it then. \$\endgroup\$ – Peter Smith Nov 10 '15 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.