1
\$\begingroup\$

I'm trying to measure the current consumption of an accelerometer using a 1kOhm shunt at Vdd. I've read that there's a ~30kOhm resistor at SA0, so grounding it causes a much higher current draw.

When I indeed ground SA0, I see 100mV over the shunt. However, when it's connected to Vdd, I see -36mV over the shunt (measured using a UNI-T UT39A multimeter). The device works correctly, but this negative voltage doesn't seem right.

Does anyone know why pulling SA0 high causes a reversed current draw?

Thanks

EDIT

I've also tried 100R and 10R.

Here's the schematic. Note that I've picked a random part to represent the sensor. The idea is to indicate that the shunt is on the Vdd line.

enter image description here

\$\endgroup\$
9
  • \$\begingroup\$ Try reversing the meter leads. In fact it should not matter.. just disregard the sign for this measurement. The voltage across any shunt is the result of current flow.. It's all relative. \$\endgroup\$
    – Spoon
    Nov 25, 2015 at 8:39
  • \$\begingroup\$ But I already have the leads connected as they should be. Why should the sign not matter? The sign shouldn't be disregarded - right? Doesn't a negative value mean reverse current? \$\endgroup\$
    – Kar
    Nov 25, 2015 at 9:47
  • \$\begingroup\$ What more did you connect? Have you attached anything else to the accelerometer? a microcontroller, a voltmeter, anything? \$\endgroup\$
    – frarugi87
    Nov 25, 2015 at 13:40
  • \$\begingroup\$ @frarugi87 Yes, I'm driving it with an Arduino. The accelerometer is powered by the Arduino's 3.3V line. I'm using a multimeter to measure the voltage across the shunt. That's all there is. \$\endgroup\$
    – Kar
    Nov 25, 2015 at 13:45
  • \$\begingroup\$ A 5V arduino? Did you put a 5 to 3.3V level translator between the two? (i mean on the data lines, not on the power lines) \$\endgroup\$
    – frarugi87
    Nov 25, 2015 at 13:57

1 Answer 1

1
\$\begingroup\$

Your shunt resistor is way too high, to measure properly, you need a low value resistor and a differential amplifier.

In your test setup, the voltage drop on the shunt resistor might be too high for the component to operate properly.

There are off the shelf products that implement this capability.

\$\endgroup\$
7
  • \$\begingroup\$ I've tried a 100R though, and it's still a negative voltage (-3.6mV). With a 10R, it's -0.3mV. The shunt value doesn't seem to change the polarity. \$\endgroup\$
    – Kar
    Nov 25, 2015 at 8:24
  • \$\begingroup\$ Which way round are your leads? \$\endgroup\$
    – Spoon
    Nov 25, 2015 at 8:41
  • \$\begingroup\$ The leads are correctly connected. Black into the COM port and to the supposed low end of the shunt. \$\endgroup\$
    – Kar
    Nov 25, 2015 at 8:52
  • \$\begingroup\$ @Kar: what is the "supposed low end of the shunt"? that at the voltage source or that at the DUT? \$\endgroup\$
    – PlasmaHH
    Nov 25, 2015 at 10:10
  • \$\begingroup\$ @PlasmaHH That's the node between the shunt and Vdd. The shunt is connected in series with the low side connected to Vdd and the high side to voltage source. \$\endgroup\$
    – Kar
    Nov 25, 2015 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.