0
\$\begingroup\$

I recently received five of the ULN2003/28BYJ combos, as described on the below link: http://www.4tronix.co.uk/arduino/Stepper-Motors.php

I am powering the stepper controller with a 5v supply from the YwRobot breadboard power supply, which in turn is powered by a 12v wall wart. I have tried to use both the breadboard output pins and the 5v jumpers directly on the YwRobot PSU.

I am using an Arduino Nano to run the controller, and I am using digital pins 8,9,10 and 11, which are connected to cables IN1, IN2, IN3 and IN4 respectively.

Pretty much everything is stock standard as described on the 4tronix site, I am even just running their sample code, and have nothing else fancy going on.

I am not seeing any LEDs come up on the driver controller, and the motor does not turn. I have tried three of the units, and double and triple checked my wiring, but it seems for all intents and purposes that the controllers are just not getting any input.

I have tested the Arduino ports with LEDs and temperature sensors, and tested another Nano as well, to no avail.

How can I best trouble shoot the controller, or else figure out how to get these to work?

\$\endgroup\$
  • \$\begingroup\$ you did connect common ground? \$\endgroup\$ – jippie Dec 5 '15 at 22:30
  • \$\begingroup\$ I have uploaded some happy snappies of the circuit and connections Here \$\endgroup\$ – JimBoh Dec 6 '15 at 8:05
  • \$\begingroup\$ You want to check continuity of the power supply rails of your breadboard. Usually they have a break half way. Be careful not to connect +5V from the power supply to the Arduino as you have a USB powered Arduino. Only ground is sufficient. \$\endgroup\$ – jippie Dec 6 '15 at 9:21
  • \$\begingroup\$ Definitely only using Gnd from the rails when powering the Nano via USB, however if I do remove USB and connect the VIN port to the rail next to it, the Nano does power up, so common Ground should be fine (I hope this set up is what is meant with common ground, it just feels weird to have two negative terminals on the same circuit). \$\endgroup\$ – JimBoh Dec 6 '15 at 12:43
1
\$\begingroup\$

First, get yourself a cheap DMM.

Next, measure the 5 volts on the 2003 board, between V- and V+ (are you sure you connected the V- to your 5v ground?)

If you've got a good 5 volts, start measuring your control lines. If all 4 are zero (or less than about 0.5 volts), that will explain why your LEDs aren't lighting.

|improve this answer|||||
\$\endgroup\$
  • \$\begingroup\$ Cheap DMM was super cheap and the single microscopic strand of copper in the probe broke off, but that is all soldered now and I have confirmed that when the Power Supply is on, I am getting 5 volts to the bottom of the pins on the controller 5v + & - terminals. I will test the control lines, I assume I need the sketch running and will need to test for short spikes of control voltage coming in from the digital pins? \$\endgroup\$ – JimBoh Dec 6 '15 at 12:45
  • \$\begingroup\$ @JimBoh - No, set it up for a constant angle, and 2 of 4 lines should be high, and 2 low. This will be true both at the control inputs and at the motor windings. Then step once, and you should see one of the low lines go high, and one of the high lines go low. If you want to look at it while stepping, you need to get a scope. \$\endgroup\$ – WhatRoughBeast Dec 6 '15 at 17:38
  • \$\begingroup\$ Thanks for your patience and help thus far. I have one side of the DMM clamped to a common groun pin, and I used it to test each bottom of the pin on the controller board. On the input side, I get pins 1 and 3 bouncing between 2.3 and 5 volts, and pins 2 and 4 bounce between 0 and 2.3 volts. On the output side, I am getting a completely constant 0.61 volts on all 5 pins of the molex, and all of the pins on the LEDs, as well as both sides of the power jumper. \$\endgroup\$ – JimBoh Dec 6 '15 at 19:07
  • \$\begingroup\$ @JimBoh - You'll note that your inputs have no relation to the Switching Sequence diagram on the data sheet. I have no idea what the Arduino is doing, but it's pretty clearly not right. \$\endgroup\$ – WhatRoughBeast Dec 6 '15 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.