Assembled veroboard showing two capacitors with one leg each soldered together, connected to ground

This is my implementation of this circuit, for connecting a Teensy 3.0 to an MSGEQ7. It worked fine when I set it up on a breadboard, but now I've soldered it onto veroboard it doesn't.

Checking through with my multimeter, I find the capacitance between pin 8 (bottom left as pictured) and the Teensy's AGND pin (connected to the black wire in the middle) to be 79pF, rather that the 20pF* it was when I measured the component before soldering.

Is there anything wrong with soldering one leg of the 100nF from pin 6 to the leg of the 10pF? They're both meant to be connected to ground according to the schematic.

  • Looking closer at the capacitor itself, it's marked "10", which should mean it's 10pF in the first place? Might I have damaged the capacitor while soldering?
  • 1
    \$\begingroup\$ Perhaps loading from other parts of the circuit? Often you don't get the correct reading when measuring a component when its connected inside a circuit. \$\endgroup\$ Commented Dec 14, 2015 at 22:40
  • 1
    \$\begingroup\$ Its a bit hard to tell from your picture, but is +5V connected to pin 1 and GND to pin 2? I'm with ElecEnthusiast about the reading. \$\endgroup\$
    – Dejvid_no1
    Commented Dec 14, 2015 at 22:44
  • \$\begingroup\$ Yes, 5V on pin 1 and GND on pin 2. (No power connected to anything when taking this reading of course.) Ah, in theory they're connected... in practice it seems I forgot to hook those ones up 😳. But that still doesn't explain the funny capacitance measurement—I tested that first and it distracted me! \$\endgroup\$ Commented Dec 14, 2015 at 22:49
  • \$\begingroup\$ How do you measure pF to begin with? My multimeter is already very inaccurate in the nF range... \$\endgroup\$
    – FRob
    Commented Dec 14, 2015 at 23:05
  • 3
    \$\begingroup\$ Perform a relative measurement... test a 10pF right outside the circuit, then clip the leads onto the one in-circuit. If it reads 10 first then 97, it's probably right. \$\endgroup\$
    – rdtsc
    Commented Dec 14, 2015 at 23:24

2 Answers 2


The only way to be sure of a capacitor's true value is to disconnect it from the rest of the circuit before you measure it. Other components within the circuit could be contributing additional capacitance and other effects if you try to measure it in-circuit.

It's unlikely that you damaged the capacitor when soldering it in, non-electrolytic ones can usually take the heat without any risk.


I would say that possibly you have a bad or damaged capacitor, and that it should definitely be replaced...

As others have mentioned, the only real way to accurately measure the cap would be to desolder it and test it alone. Your handheld run-of-the-mill RadioShack DMM probably won't be accurate enough to read out the values, I would say use an RLC meter (one of the bench-type ones) if you can. They will be more accurate in the picofarad (or maybe even femtofarad) range.

Also, check your circuit - in the photo you posted I see the cap in question soldered in series with what looks like another cap, hence the high capacitance value. I would check the other cap is soldered where it needs to be, just in case that you actually have placed it wrong.

Another thing I noticed - you said it worked on the breadboard. Did you use this exact same cap on the breadboard? If so, try to figure out what possibly could have gone between the breadboard and the perfboard, including the demon we know as ESR.

I would also check the reputability of the manufacturer of the cap in question. If it's a crap manufacturer who make some crap quality caps, then that could be your issue, is that you have a crappy quality cap. KEMET has some good ceramics and tantalums, but if you got yours from a brand that makes bad caps and is known for it then I would say try a different brand and see if you get the same result.

Edit: Check the BadCaps forum, they might be able to help you more than I can: http://www.badcaps.net/forum/index.php


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.