0
\$\begingroup\$

I have created a library in Eagle 7.5.0, then I copied it in the folder where Eagle keeps its libraries but and I can't use it. When I try to add new component the library is not among the available ones. When I am in Eagle I can open it and modify it but I can't use it in a schematic. What am I doing wrong?

The custom library is Components

enter image description here

\$\endgroup\$
  • \$\begingroup\$ I'm not sure how much light it would shed onto your situation, but could you post a screenshot of you library as it appears in your Eagle's file tree? \$\endgroup\$ – Nick Alexeev Dec 17 '15 at 20:48
  • \$\begingroup\$ Sure see the edit. \$\endgroup\$ – Adam Dec 17 '15 at 21:09
3
\$\begingroup\$

This isn't a direct answer, but you really shouldn't put your own libraries into the directory where the Eagle libraries are. You don't know what will go there in future releases that might overwrite your files.

Create a directory for your own libraries. Then add it to the library search path.

I go further and deleted the Eagle libraries directory from the libraries search path, since the Eagle libraries are of little use and it's easier to make your own parts than vetting their, even when theirs are acceptable.

As for why you library isn't showing up, I don't know. I do what I described above and all my libraries show up all the time.

\$\endgroup\$
  • \$\begingroup\$ I will check it out! \$\endgroup\$ – Adam Dec 17 '15 at 21:09
  • \$\begingroup\$ It works. So although this is not a direct answer to my question it solved my problem. Thank you. \$\endgroup\$ – Adam Dec 17 '15 at 21:32
3
\$\begingroup\$

Note windows permissions in the ../Programs directory can cause problems with additional user libraries, @Olin Lathrop has the correct idea, make a lib folder in your eagle documents folder or anywhere other then the ../Programs installation directory. You can then add this library path to the Eagle path via the tool bar once the program is opened... I think it is under Options.

\$\endgroup\$
3
\$\begingroup\$

Make sure that you enable the library in Control Panel. Scroll to the right in the Name section and click on the small circle until it is green.

enter image description here

It will then show up when you click the Add button in a schematic.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.