2
\$\begingroup\$

I want to learn how a floppy stepper motor works so that I can latter control it with my arduino.

What I did was to test if the motor in a floppy worked before pulling it off. I used a 5v from my power supply and tested the motor while still connected to the floppy circuit. And so it did. I even figured out the sequence required for it to go forward. So, I took if off the circuit.

floppy drive motor

The problem is that when I tried to make it work again (off the floppy circuit this time) it won't turn. And now, when I connect the 5v to the terminals that worked previously, this time all I get is that I'm short-circuiting my power supply.

Any thoughts? this probably has a simple explanation, but since I'm just learning electronics as a hobby I don't know much about it yet.

\$\endgroup\$
  • \$\begingroup\$ Please can you add a bit more detail about where you applied the voltages to the motor when connected to the driver, was the driver powered when you did that? Where did you apply the 5V to the motor when not connected to the driver I.e. to which terminals. What is telling you that your 5V supply is shorted? Measured the resistance of the motor phases? What is the current rating of your 5V supply? \$\endgroup\$ – user1582568 Jan 8 '16 at 2:56
  • \$\begingroup\$ Let's call the terminals 1 to 4 from left to right. 1 and 2 are connected and so are 3 and 4. First I tested the motor on the floppy (right were the motor terminals connected to the rest of the floppy circuit) while the drive was complete disconnect from any other power source and had actually been stored for quite a while. So applying the voltage between 1 and 2 made the motor turn, so the same for 3 and 4. \$\endgroup\$ – Daniel Jan 8 '16 at 6:19
  • \$\begingroup\$ Repeating this for the same terminals while disconnected from the floppy circuit results in a short-circuit, I know this because my power supply (a computer power supply modified for bench work) shuts down, as a protection I guess. The phase resistance is about 18 ohms and the current supplied is about 80 mA. So, the current apparently is not enoug as it would require about 0.28A, howerverI don't understand why it worked when it was mounted on the floppy circuit and not now, and also why my power supply shuts down now and not before. \$\endgroup\$ – Daniel Jan 8 '16 at 6:19
3
\$\begingroup\$

These motors have one of the shaft bearings on the end of the shaft, and the other inside the motor. if the shaft is not supported externally to the the motor the rotor will get jammed.

\$\endgroup\$
  • \$\begingroup\$ You were right, I turn the shaft a bit and you can even push it a little in, after that it turned again when applying voltage between two terminas, however not as much as it did while it was connected to the circuit.. \$\endgroup\$ – Daniel Jan 8 '16 at 18:56
1
\$\begingroup\$

Motors of this type typically have a phase resistance of 10~20Ω. On 5V this would draw 0.25-0.5A. Can your power supply handle that current? If yes then measure the resistance of each phase - if either one is much lower than 10Ω then it is probably shorted out. Also check the ribbon connector for solder bridges.

The motor may not spin properly when out of the drive frame because without a bearing at the end of the shaft there is nothing to hold the rotor in line. It may rub on the stator, and perhaps even come forward and jam against the inside of the case.

\$\endgroup\$
  • \$\begingroup\$ So I checked, the phase resistance is 18Ω. And apparently my power supply only supplies about 60-80mA. \$\endgroup\$ – Daniel Jan 8 '16 at 5:41
  • \$\begingroup\$ So apparently not enough. However I don't understand why it worked when it was mounted on the floppy circuit and not now and also why my power supply shuts down (short-circuting protection I think) when I connect it to the motor now and not before. Can you help me understand that? \$\endgroup\$ – Daniel Jan 8 '16 at 5:49
  • \$\begingroup\$ Perhaps it doesn't like the inductance of the windings (which other components on the floppy board may have suppressed). Or perhaps your supply is damaged and can't put out as much as it used to. What power supply are you using? Does it have an adjustable current limit? \$\endgroup\$ – Bruce Abbott Jan 8 '16 at 7:50
  • \$\begingroup\$ It's a computer power supply, I just modified it to work as a bench power supply. I tested the current going through one of the phases by connecting a LED and a resistance to it. This way the short-circuit doesn't occurs and the LED is on but the motor never turns.. maybe this proves that its just lack of current, and the components of the floppy somehow diminished the inductance. I think I have stored somewhere a 40v power supply I took from a printer, I'll check if it works using that and report back \$\endgroup\$ – Daniel Jan 8 '16 at 8:42
  • \$\begingroup\$ Stepper motors do not move continuously with a voltage applied between 2 terminals. You need to step the applied voltage from 1 phase to another in the right pattern. I suspect that when attached the the driver, the driver was getting powered from your supply and operating the motor. Can you make the motor move slightly by applying voltage to one terminal then another? \$\endgroup\$ – user1582568 Jan 8 '16 at 10:34
0
\$\begingroup\$

You need protection shottky diode and capacitor in paralel with motor (soldered on motor contacts) just like with any relay or electromotor. Protection of some PC power supplys have sensitive and when it sense reverse polarity current is limited to some minimum.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.