2
\$\begingroup\$

I am attempting to incorporate this mosfet model into ltspice: Part Page Model

However nothing I do seems to work. I've placed the library both next to the main .asc, and in the ltspice /lib/sub directory. I have not done the main import as I should be able to just include this library somehow and use the default general nmos symbol with it.

No matter what I do I get the same error:

m1: Can't find definition of model "psmn2r0_30pl"

with the model name PSMN2R0_30PL entered into the Value field of the NMOS symbol.

I've tried following this: http://www.linear.com/solutions/5360 and got the following error using:

.lib PSMN2R0_30PL.lib

Error on line 30 : .model m1:mint nmos(vto=2.02612295371271 kp=9.2938e+02 nfs=230000000000 eta=0  level=3 l=1e-4 w=1e-4 gamma=0 phi=0.6 lambda=0 is=1e-24  js=0 pb=0.8 pbsw=0.8 cj=0 cjsw=0 cgso=0 cgdo=0 cgbo=0  tox=1e-07 xj=0 ucrit=1e4 diomod=1 vfb=0 leta=0 weta=0  u0=600 temp=0 vdd=0 xpart=0 vmax=100)
    * Unrecognized parameter "lambda" -- ignored
    * Unrecognized parameter "pbsw" -- ignored
    * Unrecognized parameter "ucrit" -- ignored
    * Unrecognized parameter "diomod" -- ignored
    * Unrecognized parameter "vfb" -- ignored
    * Unrecognized parameter "leta" -- ignored
    * Unrecognized parameter "weta" -- ignored
    * Unrecognized parameter "temp" -- ignored
    * Unrecognized parameter "vdd" -- ignored
    * Unrecognized parameter "xpart" -- ignored
Direct Newton iteration failed to find .op point.  (Use ".option noopiter" to skip.)

I'm somewhat clueless as to what's going wrong here. Does anyone know how I can properly import this without having to import and redo the whole symbol?

Thanks!

\$\endgroup\$
  • 1
    \$\begingroup\$ Here is a video you should watch. linear.com/solutions/1083 I suspect you may be missing an include statement in your schematic or something though? \$\endgroup\$ – Daniel Jan 11 '16 at 23:54
  • \$\begingroup\$ Right click the .model line after opening the spice file in LTSpice and let LTspice create the model on its own. \$\endgroup\$ – AKR Jan 12 '16 at 4:53
4
\$\begingroup\$

This is defined as a subcircuit:

.SUBCKT PSMN2R0_30PL DRAIN GATE SOURCE

LTSpice needs this to have somewhat special treatment, so you will need to do the following:

CTRL+Right click on the device and you will get this window:

Component attribute dialog

Now edit the Prefix and Value lines: The prefix for a subckt is 'X'. The model name is precisely as defined in the lib file.

Component attribute for subckt

Now click OK. You will need to add a spice directive on your schematic:

.include PSMN2R0_30PL.lib This assumes it is in the same directory as the simulation circuit.

LTSpice should now be happy with the part.

Here is what you should see on the schematic:

Updated symbol

You can, of course, add it to the LTSpice model tree, but I find it easier to use this method.

\$\endgroup\$
  • \$\begingroup\$ I got it working. The file still returns the errors listed in my question but the data being generated seems accurate. Thanks! \$\endgroup\$ – alphasierra Jan 13 '16 at 18:24
5
\$\begingroup\$
  1. You need to use the same name in the CIR file and the LIB file. Based on what you wrote it looks like you named the model psmn2r0_30pl in the M card in the CIR file, and you named it m1:mint in the .MODEL card in the LIB file. So LTSpice is not going to connect one to the other.

    A .LIB file could contain many different model cards, so LTSpice does not assume any connection between the file name and the names of the models contained in the file (For example, a file named "Fairchild_MOSFETs.LIB" might contain .MODEL cards for dozens of different MOSFET types).

  2. Some of the parameters you specified are not used in LTSpice (pbsw), some are not used for the level 1 model (ucrit). If you want to use the level 2 model where ucrit is valid, then you need to specify LEVEL=2 in the .MODEL card.

    You can see which parameters LTSpice understands in the LTSpice help files in the section LTSpice->Circuit Elements->M. Mosfet.

\$\endgroup\$
  • \$\begingroup\$ Thanks for the tips. This model is from the NXP website. 1. I renamed the model in their file to match the part number and now LTSpice is only complaining about the model statement. Interestingly enough the model states to use Level 3, most of the parameters appear to be in the list of valid arguments. Only xpart, pbsw, and vdd aren't. \$\endgroup\$ – alphasierra Jan 12 '16 at 3:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.