2
\$\begingroup\$

I have a system which looks like that:

CPU(macbook)<-->thunderbolt<-eth->ethernet media converter<-fiber->ethernet media converter<-eth->raspberry pi 2.

Both CPU and RP2 have static IPs.

If I connect an ethernet cable from my computer to the RP2 directly there is no problem, I can ping it and ssh it.

The fiber is duplex and I tried with different length (0.5, 50 and 100m) and for the 50 and 100m there is an adaptor from LC/ST because I don't have LC/LC long duplex fibers.

I tested the fibers and they are not broken since I can see light coming out. The media converters seem to communicate since the FXLINK led is blinking in both of them when I try to ping the system. I have tried disabling both firewalls from the CPU and RP2 but still the same issue. When I try to ping them I get timeout messages or similar to "No route to host" and "Host unreachable".

These are the media converters and SFP modules I am using: https://www.versatek.com/hardened-micro-1000base-t-to-1000base-sfp-ethernet-media-converter.html https://www.versatek.com/sfp-port-1000base-lx-mini-gbic-module-10km-40-75.html

The fiber is a simple patch cable and a more professional cable from the company FOSS but the 0.5m patch cable is always connected with the adaptor:

example: fiber media<-(LC-fiber(0,5)-LC)-(LC/ST adaptor)-(ST-fiber(50 or 100)-LC)-fiber media.

I hope the information I gave you is enough

Thank you for your help :)

\$\endgroup\$
1
  • \$\begingroup\$ Remove as many variables as you can. Drop the eth-fiber adapters and just use an ethernet cable. If it works, and you know your fiber cable is fine, then its the adapters. \$\endgroup\$
    – Funkyguy
    Jan 20, 2016 at 15:00

1 Answer 1

1
\$\begingroup\$

I think you have a speed mismatch issue.

Unlike most twisted pair ethernet equipment gigabit media converters are usually single speed devices. I'm not positive as to the reasoning but I think there were substantial changes on the fiber side that made supporting both systems in the same media converter difficult. This is a problem as the ethernet controller on Pi models up to and including the 3B is a 10/100 device while your media converters are gigabit devices.

I see four possible soloutions.

  1. Use a USB gigabit ethernet adaptor on the Pi.
  2. Use a gigabit switch between the Pi and media converter.
  3. Replace the media converters with 100 Mbps models.
  4. Replace the Pi with a "raspberry pi 3 model B+" which has a gigabit Ethernet controller.
\$\endgroup\$
3
  • \$\begingroup\$ True! That makes sense since I just connected the system to another computer which I guess can handle 1000M. That also explains why when I connect a 100M eth switch it does not work anymore. I'll follow your advice. I thought these devices could adapt their speed. Good learning. Thanks a lot! \$\endgroup\$
    – borias23
    Jan 20, 2016 at 14:34
  • \$\begingroup\$ you're missing the obvious, and probably even price effective choice: 4. replace the Pi with something that has Gigabit ethernet and more CPU power (what would you do with Gigabit on your Pi, anyway?), for example an Odroid XU4. \$\endgroup\$ Jan 20, 2016 at 14:34
  • \$\begingroup\$ That is also a good solution which I had in mind some time ago. Thank you Marcus \$\endgroup\$
    – borias23
    Jan 20, 2016 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.