1
\$\begingroup\$

I am using this 26MHz crystal from NDK. The specified load capacitance is 10pF, I am using two 18pF capacitors in series accordingly. The circuit is shown in figure below. The problem is that the crystal is not oscillating. I observe a constant 2.4V at OSCP and GND at OSCN [VDD for U1, which is an RF transceiver, is 3.3V].

I have an evaluation board for U1, where the same crystal (and 18pF caps) is oscillating OK - the average voltage at OSCP is 0.5V in this case. I tried replacing the crystal and the capacitors (C1,C2) on my PCB to make sure the problem is not due to defective parts - but with the same result.

Finally, the observation that is currently puzzling me is that out of desperation, I tried checking for short on C1, C2 using a digital multimeter - when the part was powered up. While C2 did not report a short, C1 did - I also noticed that the reported resistance was (negative) -600 ohm when the red probe was at point B and black probe at point A (points A, B shown in figure below). I understand that this might be due to the capacitor discharging in to the multimeter - but the problem is I do not see the same behaviour with C1 on the evaluation board where crystal is oscillating OK.

  1. What might explain the difference in behaviour for C1 b/w the evaluation board and my PCB - i.e., why don't I see a negative resistance between points B and A on the evaluation board?
  2. [For people who have experience debugging crystals] What can I try next to debug why my crystal is not oscillating?

schematic

simulate this circuit – Schematic created using CircuitLab

\$\endgroup\$
  • 4
    \$\begingroup\$ Measuring resistances on a powered circuit with a multimeter is not possible \$\endgroup\$ – PlasmaHH Jan 30 '16 at 9:06
  • \$\begingroup\$ Thanks - I am aware measuring resistance on a powered circuit is not recommended. However, I was trying to get some insight in to why the crystal was not oscillating and want to understand why the behaviour is different for C1 on my PCB vs on the evaluation board. Any ideas? \$\endgroup\$ – NK2020 Jan 30 '16 at 9:09
  • \$\begingroup\$ Could this be a poisonous pinout issue ? In the good old bad old days when I was thin and had thick hair Xtals had 2 interchangable pins .Now you get 4 and not all pinouts are the same .This happened to a work associate in layouts a couple of years ago. \$\endgroup\$ – Autistic Jan 30 '16 at 9:15
  • 1
    \$\begingroup\$ It is not only not recommended, but in the general case not possible: you should consider all your readings to be wrong \$\endgroup\$ – PlasmaHH Jan 30 '16 at 9:16
  • 1
    \$\begingroup\$ BTW, photos of both your board and the evaluation board (close-ups of where XTALs are mounted) could help us diagnose the problem \$\endgroup\$ – Lorenzo Donati Jan 30 '16 at 9:53
1
\$\begingroup\$

I observe a constant 2.4V at OSCP and GND at OSCN [VDD for U1, which is an RF transceiver, is 3.3V]

Most integrated external crystal oscillator circuits look something like this (example is from a PIC32MX MCU):-

enter image description here

An unbuffered CMOS inverter is used an amplifier, with a high value feedback resistor (Rf and/or Rp) biasing the inverter into its linear region somewhere between GND and Vcc. Due to the negative feedback, both input and output voltages should be the same (at least when the circuit is not oscillating).

The fact that your input and output voltages are wildly different suggests that either the feedback resistor is not present, the oscillator is not enabled, OSCN is shorted to ground, or the IC is damaged.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.