0
\$\begingroup\$

I took a while to errors when playing movies from the player (lock screen, reboots). After updating the firmware, still not working.( Same reboots, lock screen)

I open the media player and I have seen that has a UART port.

Pinout:

1 Ground
2 UART_RX0
3 UART_TX0
4 UART_RX1
5 UART_TX1
6 VDC 3.3v

Image below.

I tried to connect the port UART with connector Sitecom CN-104 v4002

sitecomlearningcentre.com/es/products/cn-104v4002/usb-to-serial-cable-0-6m/downloads

This mounts a PL2303 chip. I had problems with windows 7 installing driver. I tried Windows XP and GNU/ Linux. In all cases the same problem (Weird characters) in Putty program.

I connected:

UART             DB9

GND              PIN5 (GND)

UART0_TX0        PIN2 (RXD)

UART0_RX0        PIN3 (TXD)

I connected with putty.

Speed: 115200
Data bits: 8
Parity: None
Flow Control: None

I have turned off the mediaplayer and then I have started and only appear strange characters. Dmesg not the system nor the bootloader appears.

I tried different bauds. But nothing.

I have also tried to use the UART1 has and turn the wires, check the cables but not touching.

I tried to connect it directly to the DB9 port without passing through the converter. But exactly the same problem occurs.

Any help on how I can display the data sent from the port UART correctly.

Image with connected cables

UART Port http://i64.tinypic.com/30xkgeq.jpg

\$\endgroup\$

closed as unclear what you're asking by brhans, Daniel Grillo, Michael Karas, Null, Andy aka Feb 17 '16 at 18:18

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    \$\begingroup\$ I have no idea what you're asking about. \$\endgroup\$ – brhans Feb 9 '16 at 16:18
  • \$\begingroup\$ I'm sorry, the question is regarding how I view the information correctly. \$\endgroup\$ – Backglass Feb 9 '16 at 16:22
  • 1
    \$\begingroup\$ Are you expecting this to be a Linux console port? Why? It could just carry binary data intended for an add-on board. \$\endgroup\$ – Steve G Feb 9 '16 at 16:37
  • \$\begingroup\$ Hi SteveG, I can connect via telnet to the device. This device use Linux Venus 2.6.12.6-VENUS with BusyBox v1.1.3 \$\endgroup\$ – Backglass Feb 9 '16 at 16:45
  • 1
    \$\begingroup\$ @Backglass the fact that it has telnet does not mean that the UART port is a console port to which you can type commands. It could just send and receive binary data which is not human readable. I think you need to try the AV forums to see if anyone has determined what the UART port is used for. \$\endgroup\$ – Steve G Feb 9 '16 at 17:02
0
\$\begingroup\$

Serial ports are always hard to work with if you don't know what speed they are operating at. You need to somehow definitively determine the speed of the serial port, find it in a manual, get it from the manufacturer. You also need to determine if the port is using hardware control, if you have the correct number of stop bits, the number of data bits. Get a cheap oscilloscope, and learn about serial waveforms and you can debug the port that way. A serial analyzer might help, but usually you have to know the speed, stop bits, data bits ect. You could also try every combination but if you don't know what the port is sending then it could look like random garbage but actually be a bit stream.

\$\endgroup\$
  • \$\begingroup\$ Hi laptop2d, I can't not find the chipset datasheet. Seeking media players clones, I found using the standard 115200,8N1 rtd1261.wikidot.com/forum/t-350407/… \$\endgroup\$ – Backglass Feb 9 '16 at 16:52
  • 1
    \$\begingroup\$ @Backglass Have you read also the statements: Beware, this connector is 3.3V TTL-compliant, you should NOT connect it directly to a serial port but use a 3.3V RS232 converter (MAX3232 or eq). \$\endgroup\$ – Marko Buršič Feb 9 '16 at 16:56
  • \$\begingroup\$ @Marko Buršič I think the cable Cn-104v2 have a MAX3232 inside or a similar chip. I have not found the cable datasheet. But I think the cable is already prepared for this task. \$\endgroup\$ – Backglass Feb 9 '16 at 17:07
  • \$\begingroup\$ @Backglass Yes probably it has, but in the opposite way. USB<->PL chip(TTL level)<->MAX232<->RS232 level DB9 connector. Because the converters with TTL level don't have the DB9 connector. What you need is USB to RS232(TTL) , no MAX232 in between. Google USB to RS232 TTL converter, or you attach a second converter RS232 to TTL. \$\endgroup\$ – Marko Buršič Feb 9 '16 at 17:38
  • \$\begingroup\$ Searching for USB to UART would be much more fruitful. RS232 is a specific flavor of UART with the high voltage comms. \$\endgroup\$ – Tom Carpenter Feb 9 '16 at 19:48
0
\$\begingroup\$

two basic things, If you assume the board under test is outputting something, then you measure that output with a scope. Is it ttl or is it rs232 levels? and what is the baud rate/frequency. even if not transmitting something you might be able to tell rs232 from ttl.

Then you have to match that with your host uart interface, rs232 or not, if not 1.8volts, 3.3, 5.0, or any other that you have to limit to. then check the baud.

another simple test is short the host side rx to tx, and see that when you type on the dumb terminal software you see what you typed come back. remove the short, then nothing should come back. put the short on the scope and see that the right levels and baud is what you set it to.

lastly flow control, start with it off on the host side, might need it on the target side, if so you might be able to short rts to cts.

\$\endgroup\$

Not the answer you're looking for? Browse other questions tagged or ask your own question.