0
\$\begingroup\$

I can cycle through all the modes of interactive routing, but Altium doesn't seem to care. Any trace I lay will just step right over other nets that already exist, with no effort to push or avoid. A DRC error is instantly generated because of the short circuit this creates. Why is my interactive routing not working properly?

\$\endgroup\$
  • 2
    \$\begingroup\$ Are you violating the clearance rule even from the starting point? This is a problem I also have when the starting point is already violating a rule (it allows me to draw a route but without smart placing and complaining as soon as I finish routing) \$\endgroup\$ – frarugi87 Feb 18 '16 at 17:24
  • \$\begingroup\$ So in the status bar, when you hit Shift+Space you can see it cycle past the 'Ignore Obstacles' setting and it still does it? That is really weird -- I don't recall a setting in Altium that overrides that... \$\endgroup\$ – Krunal Desai Feb 18 '16 at 18:51
  • \$\begingroup\$ I can't paste a picture in a comment, but what does your interactive routing options tab look like? imgur.com/NkAFZcp.png \$\endgroup\$ – Krunal Desai Feb 18 '16 at 18:53
  • 1
    \$\begingroup\$ I agree with @frarugi87. If your clearance rules are set too high and it is impossible to route within the clearance constraints, it will simply route over everything in the way and will generate an error. I expect this is exactly what your problem is. Go in to Design-->Rules and edit the clearance rule. Make it as small as you can for your particular design and manufacturer's specs. If it is still too close, then spread out your traces and components further. If it is not a clearance rule, then make sure "avoid obstacles" is checked in your Preferences-->PCB Editor settings \$\endgroup\$ – DerStrom8 Feb 18 '16 at 21:25
  • 1
    \$\begingroup\$ @frarugi87 This did turn out to be the case. If you would care to post it as an answer... \$\endgroup\$ – Stephen Collings Jun 7 '16 at 17:52
2
\$\begingroup\$

As the OP is asking, I'm posting the comment as an answer, since this was the real problem.

The behavior the OP was experiencing was due to the fact that the clearance rule was violated even at the starting point. It appears that if the routing violates rules at the starting point the smart placing feature does not work, and as soon as the line is completed the online checker complains.

The user can notice this because the line he starts drawing can go even on nearby pins.

The way to solve this is simple: avoid violating rules at the very first point of the routing

\$\endgroup\$
1
\$\begingroup\$

I was trying to solve the same problem. so I noticed what was wrong in my settings: In "design>design rules>clearances", from the dropdown menu of "where the first object matches" must be selected as "All".

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.