5
\$\begingroup\$

I am hoping someone here can help me.

I am having trouble with a RFID kit I bought from SparkFun. I purchased the USB RFID (SEN-08852) with the RFID Reader ID-12 (SEN-08419) and some RFID cards.

When I hook up the reader or try to use it, it goes into a constant "read" mode. The green "Read" LED flashes constantly and the buzzer clicks with each flash. This will not stop until I unhook the USB cable.

I have found that if I connect the USB part without the reader and then connect the reader to the board, the device works properly for the very first RFID card (and I can read the serial output using PuTTY). As soon as the first card is read, it starts the read loop again.

Any ideas as to why this is happening? Is my device broken, or am I just doing something wrong?

I have Windows 7 x64, and I did not install any drivers when I hooked up the reader - Windows downloaded them for me.

Edit: Apparently the port I was using wasn't providing enough power for the reader - once I tried a powered hub (and eventually another port on my laptop), it was working flawlessly! I now have no problems swiping a card more than once.

\$\endgroup\$
3
\$\begingroup\$

Have you tried using a powered USB hub?

\$\endgroup\$
  • \$\begingroup\$ I was testing on my laptop (Dell Inspiron 1501) with the device plugged in to the USB port on the side of the laptop, but that's not a bad thought! I'll try on my desktop, both in the motherboard USB and a powered hub. \$\endgroup\$ – Jared Harley Apr 15 '10 at 0:30
  • \$\begingroup\$ You were right! I guess the port I was using wasn't giving it enough power - I hooked it up to a USB hub, and it started working right away - thanks! \$\endgroup\$ – Jared Harley Apr 15 '10 at 22:29
2
\$\begingroup\$

I have used one of these before, specifically the one from Sparkfun and it worked correctly. I suggest at this point that you try to wire it up in your own circuit with the ID12 for testing (the datasheet has all the pinout information you should need).

You don't need to connect an antenna; just wire pin 10 to an LED and try swiping some cards. If it works fine I would consider contacting sparkfun for a replacement USB board because there is something funky going on there (after trying it in another PC of course).

\$\endgroup\$
0
\$\begingroup\$

Try the Sparkfun forum. Lots of people there seem to be using them successfully.

\$\endgroup\$
  • \$\begingroup\$ I actually have and haven't got any response. I'm hoping someone here can help me out, though. forum.sparkfun.com/viewtopic.php?f=13&t=19693 \$\endgroup\$ – Jared Harley Apr 14 '10 at 19:37
  • \$\begingroup\$ There have been several posts there in the past. Try searching for them. \$\endgroup\$ – Leon Heller Apr 14 '10 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.