0
\$\begingroup\$

I am using this level shifter spark fun breakout board: https://learn.sparkfun.com/tutorials/using-the-logic-level-converter

My goal is to interface a 5V logic SPI LCD with a 3.3V logic micro controller. To start I have been testing the level shifter board to make sure I can get the correct levels. I apply 3.3 V from the micro controller to the TXI pin and get 5V on the TXO pin no problem. The issue is when I apply 0V to the TXI pin. This results in a 1.4V on the TXO pin. From the spark fun board schematic I see that it is using a MOSFET to apply the conversion and from my understanding when one side of the MOSFET is pulled low it enters into a conducting state and this should result in both sides going low. I don't understand why I'm seeing the 1.4V as opposed to just 0V.

If I'm stuck with the MOSFET going to 1.4 V for low-level logic should I expect my SPI LCD to treat 1.4 V as low-level logic and then operate correctly?

\$\endgroup\$
  • \$\begingroup\$ Applying 0V on the low side indeed turns the FET on. Have you tried measuring the output with no load attached? You may be seeing a voltage divider effect. \$\endgroup\$ – Peter Smith Mar 19 '16 at 17:01
  • \$\begingroup\$ I found the issue now. It had nothing to do with what I asked in the question. The 3.3 V power that I was supplying to the breakout board wasn't actually turned on. Once I fixed this the level shifter works as advertised. \$\endgroup\$ – JeremiahOgletree Mar 19 '16 at 17:14
  • \$\begingroup\$ Answer your own question as that will show the issue has been solved. \$\endgroup\$ – Peter Smith Mar 19 '16 at 17:15
1
\$\begingroup\$

Found the issue. I simply wasn't powering the breakout board properly.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.