0
\$\begingroup\$

schematic

simulate this circuit – Schematic created using CircuitLab I am using the following circuit with given component values. I am not getting a proper level of output from Ho or Lo pin to drive the MOSFETs. The voltage level is in mV. Also, the square waveform that I should be getting from Ho and Lo pin is not very crisp. I have not connected the load yet. This circuit is being used for Class D Audio Amplifier. Any suggestion why the the Driver IC2104 is not working?

\$\endgroup\$
  • 2
    \$\begingroup\$ We're not going to read your netlist and draw it. Edit your question using the schematic button somewhere in the middle of the top bar. Also, please be so polite as to review what it looks like before you press submit. This needs more enters. \$\endgroup\$ – Asmyldof Mar 31 '16 at 22:32
  • 1
    \$\begingroup\$ Please add a schematic. You can add a schematic via the built-in schematic editor in the post editor. \$\endgroup\$ – uint128_t Mar 31 '16 at 22:32
  • \$\begingroup\$ Originally you said "Ho pin output is varying from +4.4V to -4.4V and Lo pin output is varying from +5 to -5.". This make no sense (the IR2104 cannot generate negative voltages). Please make sure the scope inputs are set to DC, and show us the waveforms at HO, LO, and Vs. Also check that your FETs are connected correctly. \$\endgroup\$ – Bruce Abbott Apr 1 '16 at 18:34
  • \$\begingroup\$ @BruceAbbott Yes, that was an error, which I tried to rectify today but ended up getting output in mV instead. I have connected the MOSFET exactly as shown in the schematic that I have provided. The outputs from Ho and Lo are not very crisp square wave, plus they are in millivolts. \$\endgroup\$ – Ankit Sahay Apr 1 '16 at 18:36
  • 1
    \$\begingroup\$ Remove the FETs and look at LO - you should get a square wave going from 0V to Vcc. If not then you are not providing correct voltages (Vcc must be >=10V), or the IR2104 is wired incorrectly, or it is blown up. If you get the correct waveform then the FET is blown. \$\endgroup\$ – Bruce Abbott Apr 1 '16 at 18:46
1
\$\begingroup\$
  1. As Mario states, you must use a large enough capacitor. I generally use a 1uF to 4.7uF 0805 ceramic capacitor for this bootstrap capacitor.

  2. Check your diode polarity. It is correct in the schematic, but it is one of the easiest things to mess up in this circuit.

  3. Additionally, you MUST continually 'toggle' the capacitor, meaning that the lower MOSFET MUST be periodically turned on in order to refresh the charge across the bootstrap cap. If you leave the upper MOSFET on for too long, the capacitor voltage will begin to droop and your FET will move into the linear region. Try driving with a square wave of at least 20kHz.

\$\endgroup\$
  • \$\begingroup\$ 1. I will definitely try with large capacitor. 2. The diode polarity is correct, I am 100% sure as I have been working on this circuit for 6 straight hours. 3. How do I toggle the capacitor? Will that be automatic or do I have to introduce any change in the circuit? \$\endgroup\$ – Ankit Sahay Apr 1 '16 at 18:29
  • \$\begingroup\$ Toggle the input to your IC at a frequency. Use a 20kHz square wave on your 'IN' pin. In order to refresh the charge on Cboot, the output MUST be toggled periodically. \$\endgroup\$ – slightlynybbled Apr 1 '16 at 18:41
  • \$\begingroup\$ I did try with square wave as well, varied it from 50Hz to some 100s of Hz. 2. How do I ensure that output is getting toggled as you said? \$\endgroup\$ – Ankit Sahay Apr 1 '16 at 18:44
  • \$\begingroup\$ That is your problem, 50Hz is WAAAAYYYY too slow :)... so is 100s of Hz.... you need to be in the 10000s \$\endgroup\$ – slightlynybbled Apr 1 '16 at 18:46
  • \$\begingroup\$ I tried 50Hz only because it wasn't working in KHzs. Initially I was working in some 50-60kHz range \$\endgroup\$ – Ankit Sahay Apr 1 '16 at 18:47
0
\$\begingroup\$

The capacitor C1 needs to provide the gate charge for the MOS transistor. A 100nF capacitor is too small. Try something in the order of 10uF.

It is also required to switch M2 first, otherwise C1 can't get charged. Depending on the application a startup circuit could be required.

\$\endgroup\$
  • \$\begingroup\$ I tried with different capacitors. In fact I connected a decade capacitance box and varies it with all possible value. The circuit still doesnt seem to work \$\endgroup\$ – Ankit Sahay Apr 1 '16 at 18:20
  • \$\begingroup\$ That adds a lot of inductance, too. Use a 10uF cap. \$\endgroup\$ – Mario Apr 1 '16 at 18:21
  • \$\begingroup\$ I have tried till 1uF electrolytic capacitors. I will try with 10uF as well. Is there anything else that could possibly go wrong in the above circuit? \$\endgroup\$ – Ankit Sahay Apr 1 '16 at 18:22
  • \$\begingroup\$ You need to make sure that M2 switches first in order to charge C1. Then you should use an additional capacitor between VCC and COM. \$\endgroup\$ – Mario Apr 1 '16 at 18:26
  • \$\begingroup\$ How do I ensure that M2 switches first? Do I have to introduce some changes in the circuit? 2. What should be the value of capacitor between Vcc and COM? \$\endgroup\$ – Ankit Sahay Apr 1 '16 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.