0
\$\begingroup\$

For some reason when current biasing a very simple BJT common emitter circuit in ltspice, the current source needs to produce a massive amount of voltage. Why would this be? I'm biasing it at a Q point of 3mA

Here's the circuit https://www.dropbox.com/s/is0iqjgewsd9lrk/currentbias.asc?dl=0

Here is a picture of the circuit enter image description here

\$\endgroup\$
  • 1
    \$\begingroup\$ Please provide a schematic of your circuit. (Don't expect us to download an ASC file and load it in to LTSpice to see the circuit). If you don't have enough priveledges to insert the graphic directly, leave us a link and someone will edit it into your question. \$\endgroup\$ – The Photon Apr 25 '16 at 3:43
2
\$\begingroup\$

the current source needs to produce a massive amount of voltage. Why would this be?

Because you haven't provided any path for current to flow into the base, you aren't operating the transistor in the forward active regime.

Instead you're just driving the collector-emitter junction in reverse. If the device model includes this behavior you might be driving the c-e junction to zener breakdown. If the model doesn't include breakdown behavior, you're probably driving the 3 mA through the "hidden" gigohm resistors to ground that the simulator typically adds to each node to avoid circuits being unsolvable.

\$\endgroup\$
  • \$\begingroup\$ Oh, i see thanks. Also, is there any benefit to driving the base with a current mirror instead of a voltage source and resistor? \$\endgroup\$ – gorge Apr 25 '16 at 5:53
  • \$\begingroup\$ @gorge, it depends what problem you're trying to solve. And are you implementing this with discretes or on an IC? \$\endgroup\$ – The Photon Apr 25 '16 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.