0
\$\begingroup\$

First of all, I'm fairly new to electronics. I've been working on my own version of a miniature hovercraft just like this one http://www.thingiverse.com/thing:68639. I'm using an arduino pro mini for the controller, a nrf24l01 transceiver, small brushed motors (hubsan motors) running at 3 volts and a 3.7v 500mah 25c lips. I'm also using MOSFET transistors for the speed control. Here's the problem. I wired everything according to this page http://www.circuitmagic.com/arduino/run-small-brushed-motor-for-mini-quadcopter/, but when I turn the motors on, there's a huge voltage drop. When plugging one motor directly to the battery, it drops about one volt. When attaching two motors, the voltage drops down to 0.86 volts.

I don't know how to provide a steady 3.7 volts to my motors (without it dropping significantly), but I know it's possible since quadcopters like cheerson cx-10 runs four similar motors using a 3.7v 100mah lipo while I'm only using two motors. For that matter, how are micro quadcopters running multiple brushed motors without the motors running slow. I can only get a gentle breeze from mine. Please tell me if there's a way to regulate voltage or any other step or component I'm missing in my setup.

\$\endgroup\$
  • \$\begingroup\$ Can you post specifications of the motor? It sounds like the battery can't provide enough current, possibly because it is bad. With motor specs, we can determine whether it SHOULD work. \$\endgroup\$ – Mark Apr 26 '16 at 2:05
  • \$\begingroup\$ It rather looks like you have a cell with fake specs. Try running your motor off two AA cells and measuring the current drawn - without a prop mounted it shouldn't be much, but with one attached it could be an amp or two. \$\endgroup\$ – Chris Stratton Apr 26 '16 at 3:36
  • \$\begingroup\$ Dc Motors(serial) starting current is ∞ (infinite (Theoretically,(what is your power))) on starting. But your battery or circuit got problem(example: Battery voltage down if haven't charge or corrupted a cell ). Test with another battery or try charging... \$\endgroup\$ – dsgdfg Apr 26 '16 at 7:32
  • \$\begingroup\$ @dsgdfg - these tiny motors have very little rotor inertia, and their load is a propeller that unlike a wheel isn't much of a load until it is rotating fast, so "starting" is something that is going to be finished long before the poster can measure the voltage drop with anything short of a scope. This is a steady state problem, not a startup one. Perhaps the propellers are too big - budget online vendors don't necessarily sell well matched parts. \$\endgroup\$ – Chris Stratton Apr 26 '16 at 16:41
  • \$\begingroup\$ @ChrisStratton propellers is good point. Drop down voltage because motor can't reached KV value. Can't change motor on related prototype, need bigger battery, bigger body, everything’s are changed ! My opinion he is not calculated motor power and propellers size. \$\endgroup\$ – dsgdfg Apr 27 '16 at 8:02
-1
\$\begingroup\$

It is likely you can solve your problem by starting your motor slow then ramping up the speed. Tutorials are all over the web to do this. Here are three: 1, 2, 3.

To control motors the Arduino generates a fast pulsing signal that switches on and off over and over. The frequency is generally constant. However the duty cycle can vary. To make a motor go slow the on part is very small compared to the off part. This type of signal has a low duty cycle. Perhaps 0% to 25%. To make a motor go fast the on part is very large compared to the off part. This type of signal has a high duty cycle. Perhaps 75% to 100%. The following image shows duty cycles from 0% to 100%:

enter image description here

The Arduino function call analogWrite() is the secret to controlling the duty cycle of the Pulse Width Modulator (PWM) feature.

\$\endgroup\$
  • \$\begingroup\$ I just tried the pwm control with analogWrite() using the code from the third website and I still experience the same voltage drop. It's the exact same drop if I slowly get it running compared to immediately sending a HIGH signal. Could it be that my battery is bad? \$\endgroup\$ – Eammon Apr 26 '16 at 1:52
  • \$\begingroup\$ Wow, you're quick. To be honest the above is the only reasonable solution I can think of. If you suspect your batteries I would try a good sized power supply. Also check for bad or loose power connections. And use good sized short wires between the batteries and motors. Pulling current through long thin wires can result in sizable voltage drops. \$\endgroup\$ – st2000 Apr 26 '16 at 2:18
  • \$\begingroup\$ I'm wondering why someone would vote this answer down without a comment? \$\endgroup\$ – Mark Apr 26 '16 at 3:21
  • \$\begingroup\$ Unfortunately, the wires I'm using to connect to the motors are thicker than the wires coming out of the motors. I can't really change the thickness of the motor wires since the terminal is hidden. Funny thing is, I've used other motors and they're completely fine. The problematic motors only cause a voltage drop when I put the propellers that came with it on. \$\endgroup\$ – Eammon Apr 26 '16 at 5:40
-1
\$\begingroup\$

The mosfet may simply be the wrong way around, unfortunately not all fets have the same pinout. The gate (G) goes to the arduino, the Source (S) goes to ground and the Drain (D) goes to the motor and then the other motor terminal to the positive battery terminal. Another possible problem could be that the mosfet you've got might need more voltage to fully turn on than the arduino can provide, some mosfets don't fully turn on until Vgs hits 6V, although some only need a volt or two to be fully on, the minimum voltage to turn the fet on is called the threshold voltage (Vth) and should be in the datasheet for the mosfet somewhere.

\$\endgroup\$
  • 1
    \$\begingroup\$ He has shown that it's not the MosFET, as he has the voltage drop when he connects the motor directly to the battery. It's a motor<->battery thing. \$\endgroup\$ – Mark Apr 26 '16 at 3:22
  • \$\begingroup\$ I've also tried several npn transistors I had laying around that was rated for the voltage I needed, but still no luck. \$\endgroup\$ – Eammon Apr 26 '16 at 5:36
  • \$\begingroup\$ Oh, the drop is directly across the battery? My mistake, in that case it looks like Mike and Chris have it, underperforming battery. If you've got a bigger battery, see if you get the same issue (some D cells would be great, AAs might do it in short bursts) otherwise try a plug-in supply \$\endgroup\$ – Sam Apr 26 '16 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.