0
\$\begingroup\$

I am direly confused on this. I've used 220 Ohm resistors in the past for all of my LEDs (at least that I can remember), however nothing on my arduino+breadboard with a few leds on the 5V breadboard rail had worked.

I finally looked at the data sheet for the LEDs from the overseas place I ordered them from, and they seemed to require 35mA or so rather than 25.

I calculated that to be ~80 Ohms (5V-2V(drop) = 3V / 0.035A) = ~85 Ohm.

This explained perfectly why they had not started working, so I pulled out a 100 Ohm (which read out to about 95 with a multimetre) and set it up.

Now the LED did not light, to my surprise, feeling the resistor which was just out of curiosity felt sharply cold - of course realizing that it is so hot it overloaded the nerve endings on my fingers being too hot to touch.

My rough calculations were:

3V / 95 = ~35mA, and 3V? * 0.035A = .105W, seemingly not enough to cause much heat at all, especially over 3-5 seconds and being rated for ~.25W

Can you understand what I am doing wrong, or what could be going wrong?

My circuit is just 5V pin -> breadboard -> 100Ohm resistor -> LED -> Ground pin.

I just cannot make sense of it.

edit: I very recently shorted an LED without a resistor from 5v->gnd, possibly damaged something..

\$\endgroup\$
  • 2
    \$\begingroup\$ Do you have a DMM? Have you tried testing the LED in "Diode" test mode? Have you tried placing the DMM in series with the circuit in Ammeter mode to read the current in the circuit? \$\endgroup\$ – Majenko Dec 3 '11 at 11:19
  • 1
    \$\begingroup\$ Spec. for the LEDs? You seem to be running them at their max. current - why? \$\endgroup\$ – Leon Heller Dec 3 '11 at 13:25
  • 1
    \$\begingroup\$ Are you 100% sure these are visible LED's? I had a batch of "bad" junkbox ones, that I finally figured out were IR even though they looked like they "should" be visible - looking at them through a digital camera confirmed they actually were emitting, just not at a wavelength I could see. Outright fakes or failed batches are additional possibilities \$\endgroup\$ – Chris Stratton Dec 3 '11 at 15:42
  • \$\begingroup\$ @comments, I hadn't realized the diode voltage drop indicator could actually light LEDs with its small battery, it seems it all works. Definitely will get rest before I interpret data sheets.. 220 Ohm ran it at 20mA, so I assumed 35 (near max) would make it shine when it hadn't. \$\endgroup\$ – Kenny Robinson Dec 3 '11 at 22:42
2
\$\begingroup\$
  1. I've used 220 Ohm resistors in the past for all of my LEDs (at least that I can remember), however nothing on my arduino+breadboard with a few leds on the 5V breadboard rail had worked.
     
    Blindly using a value based on lore or superstition instead of math is a bad idea.
  2. I finally looked at the data sheet
     
    Wow, what a radical idea! Just imagine, now the people that design a part do the careful research, find out its parameters, and publish them. We can read their results and recommendations and use mathematical calculations to decide how best to use the part and have a good idea up front what it will do. No more waving of dead fish during a full moon. This changes everything!!
  3. This explained perfectly why they had not started working
     
    No, it doesn't. The maximum current rating is just that, the maximum the LED can take. The light output of a LED is pretty much proportional to the current thru it. While your LEDs could have been driven with 35mA, they would certainly have lit up noticably at half that or a quarter of that unless perhaps you were viewing them in direct sunlight. Humans perceive light intensity logarithmically, not linearly. That means each halving of light level looks like a fixed increment to us. For example, the sequence of 100%, 50%, 25%, and 12.5% of max brightness will look like roughly even steps towards dark to us.
  4. So was the resistor really hot or cold? I've touched a few hot parts in my career, including getting burned a few times, and it's never felt cold. Really hot feels hot, and you have a reflex reaction to pull your hand back before the brain engages in concious thought. This concept of overloading the nerve endings makes no sense, and makes me think it really was cold and you just somehow convinced yourself it was hot.
  5. You are right, a 95Ω resistor with 3V accross it will dissipate about 100 mW. That is enough to make a 0805 obviously hot, but shouldn't burn your finger. A 1/4 Watt thru hole resistor should be noticalby warm but not so hot you can't hold it for a while.

Something is not as you think, but it's not clear what. Have you tried the LED in both orientations? It sounds like it is hooked up backwards and therefore not lighting.

I would use a 300Ω or so resistor with your 5V supply and try several different LEDs. Just about any LED you are likely to get can take 20mA, so the 300Ω will limit the current to well within the safe operating range while still allowing for plenty of brightness indoors on your bench. If in doubt, get another known working LED from someplace and figure out how to make it light. Then substitute your LEDs trying both orientations. If they don't light, then they are blown.

\$\endgroup\$
  • \$\begingroup\$ You've never dipped your finger in near boiling water, or touch a burner accidentally without realizing there is a split second between nothing, and the pain being realized by your brain? I really needed a good nights sleep before looking at this, should have done so - but a second opinion was very helpful when I gave up. A 120 Ohm resistor made it shine brightly with small heat - so I am going to use the 3.3V rail (if it can be used for this) and use a 65 or so Ohm resistor @ 26 milliwatts dissipation. Thank you Olin for kicking me in the right direction. \$\endgroup\$ – Kenny Robinson Dec 3 '11 at 22:39
  • 2
    \$\begingroup\$ @Kenny: Again, you don't have to use the full current the LED is rated for. Usually half that or less is fine unless the device will be used in bright conditions like sunlight or something. \$\endgroup\$ – Olin Lathrop Dec 3 '11 at 23:03
0
\$\begingroup\$

A dumb question, but could very well be the answer. Are you using a breadboard and placing the resistor and led accidentally in parallel? I have seen many times fellow class mates placing them on the same "column" to save space.

\$\endgroup\$
0
\$\begingroup\$

IF the LED is in series with the resistor then it should not get that hot.
If it is a 100 ohm resistor it should not get that hot.
P100 = V^2/R = 25/100 = 0.25 Watt.

BUT if you are using a 10 ohm resistor
P = V^2/R = 25/10 = 2.5 W.

You use 2V for LED fwd voltage drop - implying they are red ir IR or similar.
Assuming that is correct then IF the resistor is 10R and not 100R then
I = (5-2)/10 = 300 mA.
The LED will probably die, the resistor will get hot.

Get a 10k (10,000 ohm) resistor.
Place in series with LED.
Power from 5V.
Viewed in a dark room the LED should glow a very small amount.
Try this with a known good LED.
If no glow, reverse LED.
if no glow both ways "you have problems".

A data sheet should make the connections obvious.

What is the part number.
Please provide a link to the datasheet

Very few LEDs are 35 mA rated fwiw.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.