0
\$\begingroup\$

I had a board with 3 LEDs, two driven by an AtXmega325e and one simply connected to the rails. The rails are 3.3V, the series resistors 70ohms.

schematic

simulate this circuit – Schematic created using CircuitLab

All LEDs stopped working at once, yet the rest of the board (OpAmps, ADC, UART) seemed completely functional. After replacing the LEDs, the new ones worked as intended again, so I must have damaged the LEDs themselves somehow. I am not sure whether they were oriented correctly, but they did not light up (as they normally do (albeit dimly) when measuring the diode drop) in either direction. The diode drop function of my multimeter measured the following (disconnected from the power supply):

forward   backward 
1.7V      0.6V      driven by uC 
1.6V      0.6V      driven by uC 
0.5V      1.2V      power rails directly

The most confusing thing: After dismounting the LEDs they actually worked again. The two IO pins have been in all possible combinations (both on, etc.) but the LEDs never lit up. I lost the datasheet/name, but they are generic orange surface mount LEDs, with a max. current of 20mA (the names in the schematic are wrong). The solder joints looked completely fine, I also find it improbable that all three would be defective.

Do you have any idea what could cause this strange behaviour? How should I investigate this further?

\$\endgroup\$
  • \$\begingroup\$ Do you think I should post pictures of the schematic/layout themselves? I thought they must be rather irrelevant, as the components are only connected to rails and uC. \$\endgroup\$ – caconyrn May 3 '16 at 17:26
  • \$\begingroup\$ With the information provided there should not be any problem. Unless the actual connections are not matching it... \$\endgroup\$ – Eugene Sh. May 3 '16 at 17:31
  • \$\begingroup\$ "All LEDs stopped working at once" suggest a power failure of some sort. Assuming D2 and D1 are fed from the same rail that connects to your microcotroller, I would look for the problem there. Could be a simple bad solder joint... \$\endgroup\$ – JvO May 3 '16 at 17:32
  • 2
    \$\begingroup\$ Any flexing of you pcb whilst setting up? That can break a track. maybe re-soldering bridged the break so it now works.. \$\endgroup\$ – Spoon May 3 '16 at 18:11
  • 2
    \$\begingroup\$ Do not use the diode function on your DMM when testing in-circuit diodes. Your backward voltages are the meter driving current through the power supply. \$\endgroup\$ – WhatRoughBeast May 3 '16 at 18:32
1
\$\begingroup\$

I'm proposing a scenario (or two)...

The typical forward voltage of these LEDs is 2V so, a 70 ohm resistor is going to limit LED current to 1.3/70 = 18.6 mA (perfectly fine). If however, you managed to get 5V on the rails (by mistake) then the peak current could be 43 mA and exceed the continuous rating for the LED (30 mA).

Also, if you operated at a temperature above 50 degC then the maximum continuous current does fall - anything that might cause the LEDs to become overly hot?

\$\endgroup\$
  • \$\begingroup\$ The second one might be correct: I soldered some components (although rather far away from the LEDs) about a minute before powering the circuit. I am rather sure that it was not uncomfortably hot though; I think that >50° should be easily noticable by touch. I'll try to replicate this tomorrow and post the results. \$\endgroup\$ – caconyrn May 3 '16 at 19:16
  • \$\begingroup\$ I tortured some LEDs now (yay?) but to no avail. Even after 10min under 300° hot air (solder fluid too) but there was no malfunction. I suppose the warnings in datasheets are intended for prolonged under those conditions. \$\endgroup\$ – caconyrn May 4 '16 at 15:38
0
\$\begingroup\$

You seem to have driven too much current into the LEDs. Make you use proper current limit resistor. Too high R will make LED dim and too little resistor will allow lots of current and kill LEDs. Follow specs of LED and make sure to provide proper current by using the properly calculated resistors.

\$\endgroup\$
  • \$\begingroup\$ He did use a proper current limit resistor according to my calcs. \$\endgroup\$ – Andy aka May 3 '16 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.