0
\$\begingroup\$

I'm asking this mainly as a sanity check and to distinguish between whether I've just done something wrong or need to buy a new one.

I have a "600W" boost converter based on the UC3842A SMPS w/ CC chip.. Winfield Hill has done a pretty complete schematic which you can find here.

schematic http://cr4.globalspec.com/PostImages/201405/eBay__600W__boost-converter_sch_7D9E46E8-5056-8D7B-05C2BA65111E35F9.jpg

I'm using a 65W SMPS power supply. As a load, I'm using a 70ohm power resistor (heating element actually).

Using 19.0V in, when I turn the boost converter all the way down V-ADJ and I-ADJ 100% CCW, I get 18.9V out and a draw of 0.27A, as expected. If I turn I-ADJ all the way CW, nothing changes, as expected. Now, I turn V-ADJ CW so that I get 38V out and draw 0.55A. Everything as expected so far.

Here's the part that seems completely wrong: If I now turn I-ADJ 100% CCW (raising the resistance on the pot to 100K), very little happens. Voltage drops to 37.7V and current remains at 0.55A (probably a slight inaccuracy in my panel meter.) This is repeatable. 38V to 37.7V. This is repeatable at many other voltages as well, for example, something similar happens at 50V and 70V.

What I expect to happen is at 38V, if I turn I-ADJ 100% CCW, for the voltage to drop to 18.9V as it tries to limit the current.

Unless I'm losing my mind, this device used to work and I think I may have caused it to stop working. What I've done is replaced the 100K I-ADJ trimpot with a 100K wirewound pot. It turns out my 100K+/-5% pot is exactly 90K at max, so I've tested all of this with a 10K resistor in series with it, just in case.

So, just to clarify: I've tested the pot independently of the circuit and it's fine. I've ensured its wiring is correct and I've even reversed the wiring just to prove it to myself. Voltage adjustment is working perfectly as expected and it's also using a 100K wirewound pot instead of the default trimpot.

I've verified continuity of the pots to the correct positions on the board. I even verified continuity up to the pins of the chip. Everything is hooked up and hooked up correctly.

I've tried my best to understand how CS works on this board using the datasheet but it is honestly beyond my skill level at this point. I did some measurements anyway in hopes that they may be useful in this question:

At 18.9V, drawing 0.27A with pot set to 100Kohms, the voltage across the pot is 15mV and the voltage across V.CS(pin 3) and GND (pin 5) is 15.5mV.

At 18.9V, drawing 0.27A with pot set to 10Kohms,V.pot is 5.5mV and V.CS(3)-V.GND(5) is 9.7mV.

At 38V, drawing 0.55A with pot set to 100Kohms, V.pot is 319mV and V.CS(3)-GND(5) is 330mV.

At 38V, drawing 0.55A with pot set to 10Kohms, V.pot is 33mV and V.CS(3)-GND(5) is 50mV.

Why does it seem to work just a tiny tiny bit?

What can cause this behavior? Did I fry the LM358 when I was desoldering/soldering? It's pretty far away from the pots but it's the only thing even remotely close to them. Anything else I should test? Anything else I should try modifying?

Update 1 I tested the exact same configuration with a different boost converter and it worked as expected, so mine is broken.

Update 2 I used a 2Mohm potentiometer. At 22V, drawing 0.30A, I was only able to get down to 21.90V with the 100K pot but with the 2M pot, I could get down to 2.80V. Is there anything I can do to fix it or at least further diagnose the problem?

\$\endgroup\$
  • \$\begingroup\$ This is all repeatable with different loads, by the way. I've tried with a 100W LED, Peltier cell, other resistors, etc. The heating element is just the easiest to deal with for testing. \$\endgroup\$ – Anthony May 5 '16 at 17:12
  • 1
    \$\begingroup\$ Did you wire the external pot as rheostat? \$\endgroup\$ – markrages May 5 '16 at 17:18
  • 1
    \$\begingroup\$ Just to be clear: The circuit is monitoring the peak current in the switching element (Q1). It is NOT directly monitoring the output current. The relationship between the two is not simple, depending on the operating mode of the regulator (DCM vs CCM) and the ratio between the input and output voltages. BTW, what input voltage are you using? \$\endgroup\$ – Dave Tweed May 5 '16 at 17:21
  • \$\begingroup\$ Yes, there's no choice with the PCB but I even rewired it specifically with two wires. \$\endgroup\$ – Anthony May 5 '16 at 17:21
  • \$\begingroup\$ @DaveTweed Sorry Dave, it's 19.0V on the dot loaded. I've also previously tried with a wide range of input voltages. I tried with a 12V linear power supply. I've also tried Everything in between 12V and 19V using a buck converter. To be clear, I'm not currently using any converters, just the pure 65W at 19.0V. \$\endgroup\$ – Anthony May 5 '16 at 17:26
1
+50
\$\begingroup\$

If I had to guess why the original setup with a 100kOhm pot barely has an impact, but using a 2MOhm pot does cause the voltage to fall, it would be that the voltage on the current feedback pin was too low to trigger a meaningful cutoff when using the 100kOhm pot.

schematic

simulate this circuit – Schematic created using CircuitLab

The internal circuitry will turn off the MOSFET if:

1) Vref is less than 3.6V

2) The oscillator is currently high

3) The PWM latch is currently LOW

Each time the oscillator goes high, it sets the PWM latch high and turns off the MOSFET. When the oscillator goes low, the MOSFET is turned on until either the oscillator goes high again or the feedback circuitry resets the PWM latch. OA2 in the diagram is responsible for this behavior. If the voltage on the voltage feedback pin is low (not voltage limited), then OA2- will be positive and below 1 volt (limited by the zener diode). As the voltage limit is reached, OA2- is pulled low enough that OA2+ starts to exceed it near the end of the switching cycle. This causes the PWM latch to be reset and the MOSFET to be turned off. The higher the feedback voltage, the LOWER the voltage on OA2- will be. This causes the MOSFET to be turned off earlier in the switching cycle.

The current limiting ties into this same circuit. If OA2+ (the current sensing input) exceeds OA2-, the MOSFET is turned off. Because of the Schottky diodes on your output, all of the inductor current will flow through R9 when the MOSFET is on. The current will ramp up until a threshold is reached and the MOSFET is turned off. This threshold is (Vfb-1.4V)/(3*R9) under normal circumstances, 1V/R9 (that zener diode limits it) if you are trying to produce too high of an output voltage.

The gain on the amplifier circuit you have feeding into the current sense input pin is (Rpot+3)/3, where Rpot is in kOhm. For a 100kOhm pot, that'd be a gain of about 34. The problem may be that if R9 is literally a short strip of wire, its resistance will be very low (possibly in the uOhm range), so the voltage across it for each amp of current will be correspondingly tiny. If you want to try deliberately triggering the current limiting, apply a voltage from 0 to ~1V to the current sensing pin. Somewhere in the middle the limit should become active, past ~1V it must always be active.

Increasing the gain of your amplifier by using a bigger pot or replacing R12 with a smaller resistor is one (increasingly noisy) way to cause the current limiting to activate, but the alternative is to replace R9 with a low value (~1-100mOhm) resistor. This will cause a small amount of inefficiency from the dissipated heat, but for low amperage the amount of power lost there can be quite small. Just make sure that you size the resistor properly if you intend to go to higher amperage.

\$\endgroup\$
  • \$\begingroup\$ Thank you very much for this response. I think there's a lot that I can do with this information. \$\endgroup\$ – Anthony May 9 '16 at 11:22
1
\$\begingroup\$

By replacing the standard 100K pot with a wirewound pot, you have inserted a coil of wire inside the feed back loop of a high-gain op-amp, thus you have inserted the equivalent of an inductor.

Now you have turned the current sense op-amp (LM358) into an oscillator based on the inductive value of the wirewound pot. If you hooked an oscilloscope to the output of that op-amp I bet it is full of erratic oscillations, making measurements irrational.

NEVER put an inductive device or coil of wire in the feedback loop of an op-amp. It WILL become unstable at the least and oscillate like crazy at worst.

Replace your wirewound pots with standard or even plastic style, as close to the IC as possible, and your circuit should work again. Because this would have robbed the mosfet of a proper drive signal, I do not think any damage was done. The LM358 op-amp oscillating would not have hurt it either.

\$\endgroup\$
  • \$\begingroup\$ Right... I thought about this too but nothing happened when I just tried to use a resistor or a 2M plastic pot. So maybe some damage was done? \$\endgroup\$ – Anthony May 9 '16 at 11:00
  • \$\begingroup\$ @Anthony. That is possible, and might have happened right after the change in pots. With instability the UC3843 could have been damaged, but most likely the mosfet, as it is exposed to the full power of the circuit, and does all the heavy work. Any combination of voltage or current spikes could have done so. D3 could have been damaged if enough over voltage was created by an unstable mosfet. \$\endgroup\$ – Sparky256 May 9 '16 at 18:16
  • \$\begingroup\$ Hmm, those are certainly testable things. I'll look into it. \$\endgroup\$ – Anthony May 9 '16 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.