0
\$\begingroup\$

I have this GPRS shield for arduino and I'd like to use it later on with some other standalone microcontroller. I have not been able to get it working though without connecting it to arduino and I could not find any info about the pins which are required by the onboard SIM900 chip to function properly. I have tried to get it working with arduino using jumper wires with absolutely no luck. The leds do light up, but the board does not seem to receive any issued AT commands. So which pins should I connect out of all the available pins on this board as the only requirement is that the external microcontroller should be able to send AT commands to the board to operate it?

\$\endgroup\$
1
\$\begingroup\$

The serial connection uses the pins D0 through D3. RX and tX are selectable by jumper on the GPRS module.

In addition, you will need ground and power. The GPRS module uses the Vin from the Arduino connector (on the same row of pins as reset, 3V3 and 5V) for power. It also uses the 3V3 to power the LCD.

Finally, D5 can be used as a reset on the SIM9000, and D6 is a kind of enable input. This must be set correctly to enable the SIM9000.

It appears that you also need to connect D4 as well. It doesn't seem to be used by the software examples, but it is connected to the SIM9000.

Also, does the module work without the LCD when connected directly to the Arduino?

Given that, you should be able to puzzle out which pins of the Atmega chip are actually used for what.

\$\endgroup\$
  • \$\begingroup\$ So if I'm not using the lcd, I could just leave the 3.3v connector unconnected? \$\endgroup\$ – The amateur programmer May 18 '16 at 12:24
  • \$\begingroup\$ I wouldn't do that. If unpowered, the LCD may behave oddly or (unlikely but possible) be damaged. \$\endgroup\$ – JRE May 18 '16 at 12:26
  • \$\begingroup\$ I do not have the lcd even installed on the board. Does it matter even then? \$\endgroup\$ – The amateur programmer May 18 '16 at 12:27
  • \$\begingroup\$ 3V3 appears to only be used by the LCD module. So, should be OK if the LCD module is not installed. You should double check the schematic and make sure I didn't miss something, though. \$\endgroup\$ – JRE May 18 '16 at 12:38
  • \$\begingroup\$ Now I have the module connected to arduino uno as follows: pins 2and 3 connected to input UART to the shield, vin pin from arduino connected to the shield as it normally would be and ground also. Then connected the 3.3v and digital pins 5 and 6 from the uno to the board. Board does still not answer to any AT commands. I must be missing something very simple here. Also the chip is SIM900 and not 9000. Typo? \$\endgroup\$ – The amateur programmer May 18 '16 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.