3
\$\begingroup\$

I am using Altium Designer and sometimes (very often) when I am using the Interactive Diff Pair Length Tuning even when I click properly on the wire I have this error : enter image description here

As said in the response below I have done all the necessary about PreConditions for Differential Length Tuning and I am clicking on one of the _P or _N nets.

\$\endgroup\$
  • \$\begingroup\$ The error is actually pretty descriptive. It looks like your differential pair routing rule is being violated by whatever you're trying to do. Adjust the rule to your specs, change your length tuning rule, or don't use interactive length tuning. \$\endgroup\$ – DerStrom8 May 19 '16 at 15:16
2
\$\begingroup\$

Found a solution, and it's a little bit tricky...

If you do this : enter image description here

And if you click in the position :

1) You get the Primitive not coupled error

2)&3) It's working fine, but Altium is not modifying the 1)

The trick is that you have to do a "discontinuity" in the wire, like this :

enter image description here

In :

1) You get the Primitive not coupled error

2)&3)&4) It's working fine

It looks like Altium in Differential pairs is considering a direct wire from (in this case a via) like a pad or something...

Hope you found this use full.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ So pretty much what I wrote at the end of my answer. \$\endgroup\$ – Joel Wigton May 19 '16 at 17:56
1
\$\begingroup\$

PreConditions for Differential Length Tuning

For differential pair interactive length tuning to work properly, there are a few preconditions that must be true before you can do that.

  1. Net properly defined as a differential pair (both in _P/_N naming conventions and defined as differential pairs in Class Explorer).
  2. Design rules set up for differential pair class.

Assuming this is true, you can open the length tuning dialog by pressing TAB while doing interactive differential pair routing. Note you must be in differential interactive routing mode, not regular interactive routing mode. Press TAB and bring up a dialog box like this where you can set the rules.

Options

Note: This is regular tuning options versus differential, but you get the idea. Length tuning options in Altium

"Primitive not coupled" Error Message

Now specifically on your question, assuming you have defined all of the above properly, Altium will give this error message "This primitive is not coupled within the max range" if you click on the component pad instead of the differential PCB trace. When doing differential interactive length tuning, you must start by clicking on one of the _P or _N nets. Note this is different than normal (non-differential) length tuning, where starting the routing from the component pad is OK.

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.