3
\$\begingroup\$

I am running windows 7 professional 64-bit and up until this week was running MPLAB 8.92 IDE. Now I get a brief look at the splash screen and the IDE refuses to launch. I downloaded and ran the latest version of MPLAB X and it runs, but doesn't like legacy projects with "spaces or odd characters" in the pathname. Has anyone else had this problem? I have tried the normal sources - Microchip forums, Googling, etc, and although there are examples, none of the solutions have worked. I have tried uninstalling and re-installing, running as administrator, using the -noswitch option. Any help would be greatly appreciated.

\$\endgroup\$
12
  • \$\begingroup\$ 8.92 works fine for me under Win7 pro, but it asks for permission to make changes every time it starts unless you run as administrator. Make sure nothing is popping up on a nonexistent 2nd screen or something like that. \$\endgroup\$ May 31, 2016 at 13:35
  • 1
    \$\begingroup\$ This is a better fit at SuperUser, since it's a Win7 application problem and not specifically EE. \$\endgroup\$ May 31, 2016 at 13:46
  • \$\begingroup\$ Have you tried building the project under MPLAB X despite the "spaces or odd characters" warning? I've had that warning as well several times but it hasn't caused any apparent problems. \$\endgroup\$
    – PeterJ
    May 31, 2016 at 13:56
  • 1
    \$\begingroup\$ John- is the program MPLAB.exe still running in task manager after the splash screen disappears? Did you check my suggestion about phantom screens? And did you do a re-install deleting all the files, directories and perhaps registry entries, if you're comfortable with the latter? \$\endgroup\$ May 31, 2016 at 14:25
  • 1
    \$\begingroup\$ @DmitryGrigoryev I am an SU user and I have MPLAB X... \$\endgroup\$ May 31, 2016 at 14:36

1 Answer 1

6
\$\begingroup\$

OK - found a result by desperation. In the MPLAB IDE\Utilities folder there is an executable called "SetDefaultMPLABStartup.exe." After running it the problem went away. Even a blind squirrel finds an acorn sometimes.

\$\endgroup\$
2
  • \$\begingroup\$ Thank you. The SetDefaultMPLABStartup app worked for me. \$\endgroup\$
    – BBUXTON
    Apr 12, 2018 at 22:13
  • \$\begingroup\$ Thanks, this fixed the issue for me too. \$\endgroup\$ Jul 13, 2022 at 20:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.