3
\$\begingroup\$

I've been playing with FPGA(Cyclone II EP2C5T144C8) with Quartus II 13.0 WebEdition 64bit and Altera USB Blaster.

At first, I was using JTAG mode for programming FPGA into RAM. When I wanted to program EEPROM(EPCS4), so I switched to AS mode.

Since I programmed in AS mode, I can't use JTAG mode anymore. 'Auto Detect' fuction in Programmer window responds with 'unable to scan device chain... bla bla'.

jtagconfig gives:

>jtagconfig -d
1) USB-Blaster [USB-0]
  Unable to read device chain (JTAG chain broken)

  Captured DR after reset = ()
  Captured IR after reset = ()
  Captured Bypass after reset = ()
  Captured Bypass chain = ()

However, programming in AS mode works. Seems like JTAG mode has been disabled somehow..?

\$\endgroup\$
3
\$\begingroup\$

I had the same or very similar problem ("JTAG chain broken"). It seems to solve the problem if I download libudev1:i368 and create a symbolic link

$ sudo apt-get install libudev1:i386
$ sudo ln -sf /lib/x86_64-linux-gnu/libudev.so.1 /lib/x86_64-linux-gnu/libudev.so.0

Now it works:

$ jtagconfig
  1) USB-Blaster [2-4]
  020F70DD   EP3C120/EP4CE115
\$\endgroup\$
  • 1
    \$\begingroup\$ Thanks a lot, this fixed it for me also! Intel forums were of no help. \$\endgroup\$ – jpa Feb 18 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.