2
\$\begingroup\$

I have an old P-CAD library file and need to import it to Altium. The library file format is .LIB

I tried to use Import wizard -- P-CAD Libraries and select the file. But I receive a messeage; the file is not recognized. Please select P-CAD PCB or schematic files.

I have also tried to Add Library and open the file, but could not see any component on it.

How to import or open this type of files in Altium ?

\$\endgroup\$
2
\$\begingroup\$

Altium claims in this tutorial (and also here) that it can import P-CAD's .lib libraries.

I did a quick test, which was successful. I have downloaded a P-CAD library Microchip.lib from here.

  1. in Altium. File → Import Wizard
    Click Next

  2. title: Select type of files to import
    choose P-CAD Designs and Libraries files
    Click Next

  3. title: Importing P-CAD designs
    Don't add any files (leave the list empty). You only want to import libraries, but not designs. I think, this is where the O.P. got stuck.
    Click Next

  4. title: Importing P-CAD library files
    Add library(ies) which you wish to import.
    Click Next

  5. I clicked Next in all of the remaining wizard pages, accepted defaults.

  6. After I clicked Finish, Altium created a folder called Imported Microchip.lib inside are .SchLib and .PcbLib files.

On a different occasion, I have also successfully imported P-CAD libraries in .p, .c, .d format into Altium (downloaded from here).

p.s.
This also worked for importing OrCAD libraries into Altium. (Different choice for step 2., of course.)

\$\endgroup\$
  • \$\begingroup\$ In step no.4 : I receive the following message/error: Library file not recognized. Please select P-CAD library files. As I mentioned before, the format of the file is Altium Library (.LIB) \$\endgroup\$ – G. Zambrotta Jun 13 '16 at 6:36
  • 1
    \$\begingroup\$ Do you suspect that the P-CAD library is too old, and Altium doesn't recognize its format? Maybe you can ask someone who has got P-CAD software to open your old library (hopefully, P-CAD maintained backward compatibility with it's own old libraries) and save it in a some newer format which Altium can open. [I've never run P-CAD myself, so these are only $0.02 guesses.] \$\endgroup\$ – Nick Alexeev Jun 13 '16 at 16:32
  • \$\begingroup\$ As you mentioned it seems that Altium doesn't recognize this old format anymore !! \$\endgroup\$ – G. Zambrotta Jun 14 '16 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.