4
\$\begingroup\$

Anyone know how to make UI text and objects display larger in EAGLE CAD. I just got a laptop with a 4K display and it looks beautiful but the text in some programs is microscopic

Tiny EAGLE

\$\endgroup\$
  • \$\begingroup\$ Change the DPI settings in the Windows control panel. \$\endgroup\$ – Tom Carpenter Jun 15 '16 at 17:26
  • \$\begingroup\$ Doesn't work. Tried it. Makes icons bigger, but not the little text you see \$\endgroup\$ – Dominic Luciano Jun 15 '16 at 17:36
  • \$\begingroup\$ I have been able to override the DPI scaling of particular programs by using a resource editor and screwing around with some DLLs. I can't find the tutorial I used, but this may be of help: winaero.com/blog/… \$\endgroup\$ – Bort Jun 16 '16 at 14:07
  • 3
    \$\begingroup\$ I think this is what you want: (genericmaker.com/2014/05/force-dpi-scaling-on-windows.html ) , you edit the Eagle EXE to work properly. \$\endgroup\$ – Bort Jun 16 '16 at 14:09
  • 1
    \$\begingroup\$ You rock, buddy. Worked like a charm \$\endgroup\$ – Dominic Luciano Jun 16 '16 at 20:17
5
\$\begingroup\$

With the latest version of eagle (8.4.1), on Windows 10 fall creators update, it works if you right click the EAGLE.EXE executable, go to Properties > Compatibility > check "Override high DPI scaling behavior." and set "Scaling performed by: System".

Hope this helps, cheers!

\$\endgroup\$
3
\$\begingroup\$

HOW TO FIX DPI AND SMALL FONT/TEXT ON 4K/HIDPI MONITORS:

Bolt helped me fix the problem:

"I think this is what you want: http://www.genericmaker.com/2014/05/force-dpi-scaling-on-windows.html"

You edit the EAGLE EXE (simple to do) and use CFF Explorer (as Administrator) to add "QueueDisableHook" and "DisableHook".

Rebuild Import Table, Save it, and VOILA!

This worked for my other font/DPI messed up programs too.

\$\endgroup\$
  • \$\begingroup\$ Glad you have solved it! I'd still write cadsoft about this bug: it's trivial for them to fix, and in the next release you may not need the hack anymore. \$\endgroup\$ – Dmitry Grigoryev Jun 16 '16 at 21:55
  • \$\begingroup\$ There's a couple programs I couldn't get it to work with. But so far so good with the ones that don't DPI scale properly \$\endgroup\$ – Dominic Luciano Jun 17 '16 at 3:06
  • \$\begingroup\$ This no longer works on the latest version of Eagle at time of writing (8.3.2). \$\endgroup\$ – Doormatt Oct 9 '17 at 17:56
2
\$\begingroup\$

This may not resolve your text issue, but a related issue that's worth pointing out that I just solved was having tiny unusable icons with a high dpi screen. The fix was to go into Options->User Interface... and set the icon size.

I used 32 on a 4k 15" screen. The largest it would let me set it to was 48, but that looked silly on my screen.

\$\endgroup\$
  • \$\begingroup\$ Just upgraded to 8.0.0 and had this same issue, I wish I read down far enough to read Patrick S. The genericmaker.com process did not work for me, but since this control is now in the UI screen, maybe it is no longer valid. Thanks Patrick for saving my eyes! Vote Patrick up to the top! \$\endgroup\$ – Jeffrey Drost Jan 21 '17 at 15:11
1
\$\begingroup\$

If increasing DPI changes the font size everywhere but in EAGLE, it means EAGLE doesn't use the right API to draw text, and does that by itself. Unfortunately, there's nothing you can do in that case: you'll have to either get a newer version where the issue is hopefully fixed, or lower the display resolution to increase the text size.

BTW, you didn't tell which version of Windows you're using. Assuming Windows 7, have you tried XP style DPI scaling?

\$\endgroup\$
  • \$\begingroup\$ Windows 10. You can tell from the icons and taskbar. \$\endgroup\$ – Tom Carpenter Jun 16 '16 at 13:13
  • \$\begingroup\$ @TomCarpenter Not really, for example I used to have a Vista theme in Windows XP. \$\endgroup\$ – Dmitry Grigoryev Jun 16 '16 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.