I'm having a weird problem where i cant upload my design to the DE0-NANO board, gives me the weird error message which is the title of this question.

Any other design uploads fine and I have done nothing different. Restarted the computer, rewrote the project, checked if the correct device is chosen and updated all the drivers, still doesn't upload.

Any suggestions?

  • 2
    \$\begingroup\$ Your JTAG can't see the device. You have some configuration problem we won't be able to help you with without more information. \$\endgroup\$
    – Eugene Sh.
    Jun 21, 2016 at 18:04
  • \$\begingroup\$ Looks like you probably have a bad connection somewhere, seeing as it's finding a 0x00000000 ID. \$\endgroup\$
    – DerStrom8
    Jun 21, 2016 at 18:41
  • \$\begingroup\$ Of something wrong with the tool configuration that is tied to the particular project which is failing - assuming that you actually mean that you can still load other files to the same device. \$\endgroup\$ Jun 21, 2016 at 21:09
  • \$\begingroup\$ It loads everything else except for the one project, stops at 73%. Once it gives me the error the pc doesn't recognize the device but turning the board off and on solves the problem. The design im loading is a PWM generator which is lead by a clock divider, nothing too complicated. What other info would you like? \$\endgroup\$
    – Serge
    Jun 21, 2016 at 22:46

1 Answer 1


Problem solved. I named the .sdc file differently from the name of the project. Creating a new one with the right one solved the issue, not sure why, but here we are.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.