0
\$\begingroup\$

I just run into a netlist problem with Altium Designer. As we all now, changing lot of things in schematic will completely mess up netlist and you usually need to clear all nets in PCB and add them again if you don't want to lose time with manual assigning.

Well, now a very strange thing happened to me - I have short circuits on all 0603 resistors, even that library is 100% OK, designators should be as well as unique identifiers.

Shorts are also on some pins of some ICs (SC70) and I have no idea what is going on. When I create new PCB file and force changes there, its all hunky dory.

Do some of you have any idea what is going on?

One of many examples, schematic compared to PCB:

enter image description here

enter image description here

Having custom netlabes wont help at all, it just ignores it and uses only one causing short.

\$\endgroup\$
  • \$\begingroup\$ Could you show the nets in your PCB (from PCB Panel>Nets or PCB Panel>Components) and from the ECO vs the netlist from your schematic (for some problematic components) to see what's going on? Would be helpful to know whether it assigned the same net everywhere or whether there is another pattern. \$\endgroup\$ – cx05 Jun 22 '16 at 15:50
  • \$\begingroup\$ 1. I assume you have no parts placed on the bottom side of the board. 2. Are you sure those curved lines represent net connections? I've never seen that on any version of Altium up to 15 (but 16 is out now and I haven't tried it). \$\endgroup\$ – The Photon Jun 22 '16 at 16:11
  • \$\begingroup\$ No, there are only components on TOP. Those curved lines route like real connections, so I assume they are. Wierd thing is they will stay on PCB (all of them) once I delete all nets. I need to save PCB file, close it and open again to ge them dissapear. Will add netlits and other screens soon. \$\endgroup\$ – Jaroslav Dohnal Jun 22 '16 at 16:35
  • \$\begingroup\$ Which version of Altium are you using? Does "Design>Import Changes..." find differences between the netlists? If not, the problem might also be with the schematic/compilation. Also, just to be sure, could you verify component links are intact using Project>Component Links? \$\endgroup\$ – cx05 Jun 22 '16 at 16:46
  • \$\begingroup\$ Component links are mostly intact, there are like 2 I need to resolve, but they are not causing any troubles here and have completly different netnames for them. I'm using Altium 16. Import changes finds differences in netlists (schematic is corrent, if I create new PCB file, and import netlist there, everithing is OK), but executing them won't do anything, PCB stays the same and the differences stays there as well. \$\endgroup\$ – Jaroslav Dohnal Jun 22 '16 at 16:52
2
\$\begingroup\$

By all means this seems like a bug of latest Altium version (16). I'll get in touch with Altium and start my PCB all over again.

\$\endgroup\$
  • 1
    \$\begingroup\$ Would be great if you could report back if you have any news / confirmation / workaround. This sure looks like an issue to watch out for. \$\endgroup\$ – cx05 Jun 22 '16 at 18:57
  • \$\begingroup\$ So far it seems, it has to do something with properities of altium designer. I'll check if it will be problematic even on another computer and update. \$\endgroup\$ – Jaroslav Dohnal Jun 25 '16 at 23:31
0
\$\begingroup\$

I just run into the same problem with AD 17.1 and 18.1.

I tried many different ways to resolve the issue, like deleting involved components in schematic and PCB, clearing net list in PCB, etc.

What eventually solved the issue was to delete the net labels for concerned nets in schematic, place new net labels with different names and then compile the design. After importing changes from schematic to PCB all issues was resolved.

Hope this help someone.

\$\endgroup\$
  • \$\begingroup\$ Check the jumper ID settings on the PCB footprint pads. They should all be set to 0. If they are not, they will be treated as jumpers, thus telling the program they should be connected. \$\endgroup\$ – DerStrom8 May 13 '18 at 17:43
  • \$\begingroup\$ That is a good idea, but perhaps you commented on the wrong post? \$\endgroup\$ – Mike May 14 '18 at 18:43
  • \$\begingroup\$ Perhaps I did =P The post itself is old, so I guess I replied to the latest post I saw (yours). Just added it as an official answer though, hopefully someone may find it useful. \$\endgroup\$ – DerStrom8 May 14 '18 at 18:51
0
\$\begingroup\$

Check the jumper ID settings on the PCB footprint pads. They should all be set to 0. If they are not, they will be treated as jumpers, thus telling the program they should be connected.

It is possible that when Altium updates, these are sometimes set by default (which would definitely be a bug). I vaguely remember having the same issue though back when I switched from AD16 to AD17.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.