0
\$\begingroup\$

I am working on a simple 2 layer PCB in Eagle. I have my schematic done and I have laid out the board where I think everything is most efficient.

I have created a polygon the size of the board and named it GND for a ground plane on the bottom layer.

When I click on the autorouter it detects the ground plane and has all of the thermals connected to it correctly...

Non-routed Design

As soon as I do the autorouter (settings from https://electronics.stackexchange.com/a/132346/20610) it ignores the thermals connected in the middle of the board.

enter image description here

I have tried to add the ground plane after the routing of traces only and it looks better but I know I am doing something wrong since I can't get the ground plane throughout the board.

enter image description here

How do I fix this so it auto-routes correctly and I get a ground plane with all of the thermals connected to it?

\$\endgroup\$
  • \$\begingroup\$ That's a fairly simple board, you'd be MUCH better off routing by hand. The above routing done by the autorouter is a horrific mess. \$\endgroup\$ – DerStrom8 Jul 19 '16 at 11:52
  • \$\begingroup\$ I have already gone through and done it by hand... I am trying to learn more about eagle since this is the first time I am using it and want to know what would cause something like this so I don't have this problem in the future. \$\endgroup\$ – mightymouse3062 Jul 19 '16 at 17:25
  • \$\begingroup\$ The autorouter is the problem =P \$\endgroup\$ – DerStrom8 Jul 19 '16 at 17:26
3
\$\begingroup\$

I had a similar problem. Be sure to have the termals named as your ground plane in schematic. You could do this by hand in board view.

This was the solution in my case.

step_by_step help

\$\endgroup\$
  • \$\begingroup\$ How do I verify the terminals are named ground? I have made sure the wires connected to the pins are labeled ground (I would also think that the first image of the vias being thermals with the ground plane would confirm that is the case in the first image) \$\endgroup\$ – mightymouse3062 Jul 19 '16 at 17:23
  • \$\begingroup\$ @mightymouse3062, you can check the name with the command "Info" (button "i"). Then you can rename with command NAME. I'll add a picture to better explain. \$\endgroup\$ – Antonio Jul 20 '16 at 8:08
  • \$\begingroup\$ Thank you for the help. This was what I needed to be able to get it working. Also, a comment made here helped explain it as well. \$\endgroup\$ – mightymouse3062 Jul 22 '16 at 22:02
0
\$\begingroup\$

You have bigger problems than what you describe. I see two red tracks crossing each other in the second picture. This may indicate that the layer stackup is wrong. Do a DRC and check that you only have layers 1 and 16 enabled.

Also look for polygons in other layers, like bRestrict. Display all layers and look carefully, then turn on just tRest and bRest and check them carefully too. It looks from your pictures that nothing should be in those layers.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.