0
\$\begingroup\$

I have to use MSP430i2030 for a project and I tried burning code on it using MSP430G2553 launchpad. I tried burning a simple code on toggling the LED, however, the CCS complained that it could not find the chip, yet I could see the LED being toggled. But no matter what changes I make to the code, it keeps on toggling (even when i commented that part of the code). Below is the way in which I connected my chip to the launchpad.

Can anyone please suggest an appropriate way to connect the chip to the launchpad? How do I setup the interface correctly? enter image description here

Also, as per Texas Instruments, this chip cannot be used with the launchpad, however, I have gone through some examples where people are able to use the unsupported micro-controllers as well.

\$\endgroup\$
  • \$\begingroup\$ Apparently, TI is right and those examples are wrong. \$\endgroup\$ – CL. Jul 20 '16 at 15:15
  • \$\begingroup\$ Could you suggest any other way apart from using MSP-TS430RHB32A(as per TI). \$\endgroup\$ – user3602066 Jul 20 '16 at 15:26
  • 1
    \$\begingroup\$ Without a schematic or a better picture, it's hard to tell exactly how your chip is hooked up, but if my interpretation is correct, your MSP430 has no ground connection. \$\endgroup\$ – Cheibriados Jul 20 '16 at 15:36
  • \$\begingroup\$ yes, in the current image it is not connected to ground, however, I did connect the relevant pin (AVss) to ground, yet I am getting the same error. \$\endgroup\$ – user3602066 Jul 20 '16 at 15:39
  • \$\begingroup\$ Try adding a 47k pullup to the RST line as specced by TI and see if that makes a difference. \$\endgroup\$ – Cheibriados Jul 20 '16 at 15:54
1
\$\begingroup\$

After repeated attempts to communicate with the chip using launchpad, I can finally say that it is not possible to use launchpad for programming MSP430i2030.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.