0
\$\begingroup\$

I can't seem to figure out how to link footprints I created to their schematic counterparts.

I created the schematics in the schematic library editor then connected them up in Eeschema just fine, but after creating a new footprint in the PCB footprint editor, I saved as a footprint in a new library, went back to the Eeschema window clicked >Preferences>Component Libraries>Add>path/newlibrary.pretty but my new footprint doesn't appear in the list of Component library files in that window, or in the list when I right click on a schematic component > Edit component> Footprint> Select.

I have tried to follow the steps in both of these, but they both appear to be using previous versions of the software. Does it have something to do with the .pretty folder, I don't see that mentioned in either of these.

https://www.youtube.com/watch?v=aVNMJVaRf6M

http://mithatkonar.com/wiki/doku.php/kicad/footprint_management

Thanks in advance, I am sure its something small since this is my first time using the program but I have been stuck on this for days and keep coming back to it.

\$\endgroup\$
2
\$\begingroup\$

In the Footprint Editor, click Preferences -> Footprint Libraries Manager. In the opening window, click Append Library. A new line should be added to bottom of the table. There, you should add your library's directory and nickname by hand. They both may be anything you like, but I personally put .pretty folders in related project's directory. Then click OK, of course. This should solve your problem.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.