1
\$\begingroup\$

In my experience, some signals disappear from SignalTap possible nodes because of optimization.

I wanted to make aliases to several signals and tried using noprune so they will be available at SignalTap, but I didn't see them in any category (not in the Design List category nor in the pre-synthesis category). I am using Quartus 15.1

Is there any way to make alias for signal names so they will appear for sure in the Nodes list of SignalTap?

\$\endgroup\$
1
\$\begingroup\$

I post this self-answer here since it may help others.

My brute force method was to simply SAMPLE on a clocked process ALL the signals I wanted for SignalTap (since I sample them all, they will appear with one clock delay, but all of them with the same delay).

Then I applied to all of them the noprune attribute. It is rather cumbersome and ugly, but it worked.

\$\endgroup\$
0
\$\begingroup\$

If you want to observe a specific signal without it being optimised away, you must select signals from the "Pre-Synthesis" netlist.

Doing this ensures that when you compile the original signal doesn't get optimised away because it is connected now to SignalTap so can't be.

The downside to using pre-synthesis netlist signals is that you can't do it with incremental compile partitions (e.g. Post-fit) without recompiling them from source. It is however possible to mix pre-synthesis and post-fit signal types in SignalTap.

If you are not seeing them, you may have the wrong filter settings in the SignalTap selection screen. There are different options like 'Clocks', 'Nets', 'Registers', etc. You need to look to see which category your signals end up in (by basically checking each one).

\$\endgroup\$
  • \$\begingroup\$ There are signals that do not appear not matter what settings I use, or what list like pre-synthesis or even all signals list I choose. I think that it happens because they are represented by other signals and Altera simply erases them away. I am including a self answer later on if you are interested ^^ \$\endgroup\$ – Claudio Avi Chami Jul 30 '16 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.