Can anyone provide me with some guidance on setting up a legacy serial connection on an Omega (brand) thermocouple display? I would like to use the serial data interface (Omega DP80-Ser) to reliably transfer an ASCII text string over RS-232 serial connection.

Additional information is listed below if you think you can help. Thank you for having a look at my question!

I purchased a lightly used Omega DP86T ( http://www.omega.com/pptst/DP80.html ) several months ago. The unit included several expansion cards:

  • four 6-channel thermocouple cards
  • a scaled voltage output cards which outputs a voltage proportional to a defined full-scale temperature for the channel that has been selected
  • an RS232 card that outputs an ASCII text string that includes the device number, the value on the display, the units, and then some terminating characters (spaces, carriage returns, line feeds).

After I got the thermocouples setup and was confident that the unit was working well as a stand-alone temperature display I turned my sights to getting the serial communications working so that I could used the unit in conjunction with my computer as a temperature data logger. This, of course, is where the aggravation began.

The Omega manual ( http://www.omega.com/Manuals/manualpdf/M0511.pdf ) has a reasonable description of the serial card, installing it, and setting it up in two different areas:

  • Page 2-21 talks about the layout of the card, installing it into the device, and the baud rate, word length, stop bits and parity settings.
  • Page 3-44 goes into greater detail on the parameter settings settings and the ASCII output. There is a great deal of overlap between the two sections.

I currently have the Omega serial card setup for 4800baud, 8bit word length, 1 stop bit, and even parity.

I am using a few different free programs (Termite, RS232 Data Logger, and UltraMonitor) to scan the serial input to the computer.

Of course, I have a relatively new laptop that does not have a native RS232 port (no shock there, right?) so I bought the CablesToGo USB to DB25 RS232 converter. It was well reviewed a few different places by people that were trying to hook up legacy hardware to a modern computer. (Before anyone suggest it - no, this is NOT a parallel printer interface cable.)

Unfortunately, when I hooked the Omega temperature display up to the computer via the USB/RS232 converter I got gibberish transferred to the serial terminal program. I tried messing with the Windows Hardware settings for the COM port:

  • I made sure they were exactly the same in the hardware manager; as on the Omega card; a in the logging software.
  • I tried faster and slower baud rates, different word lengths, stop bits, and parity settings on the card.
  • I tried different send/receive buffer sizes in the Windows hardware manager, and basically everything else I could think of.

Recently, I brought an old (2000) laptop home from work that still has a DB9 serial port. I connected the Omega box to the laptop with a DB9 to DB25 cable, verified the Windows settings and tried to run the data logging software but nothing happened.

This is interesting for one reason: When I was using my much newer laptop and the USB/RS232 cable the data logging software would record gibberish symbols. With the native serial port on the 12 year old laptop the system wont even handshake with the Omega box and therefore doesn't even generate the gibberish that the USB/RS232 cable did.

(For whatever it is worth, the RS232 cable by itself doesn't cause the software to log random characters.)

Most recently, I jumped pins 2&3 on the (25 pin) device end of the RS232 cable and verified that I can make a sent signal echo back to the terminal program. This test worked on but the old computer with native RS-232 interface and the new computer using USB/RS-232 adapter.

If I can't make the RS232 interface work I'll probably setup the scaled voltage output and feed that into an Arduino (or similar) so that I can get the computer interface as well as some closed loop control. So, all hope is not lost, but I'd still like to get the serial interface working - if only to win grudge match.

Any suggestions on software or hardware troubleshooting would be greatly appreciated. Thank you all.

  • \$\begingroup\$ Can you give an example of the gibberish you are receiving? Have you tried turning handshaking on/off? \$\endgroup\$
    – Oli Glaser
    Commented Jan 11, 2012 at 16:43
  • \$\begingroup\$ Oli - thanks for your help. Here's an example of the gibberish that I currently receive when I use the USB/RS-232 adapter: ÿÿþÿÿþÿÿÿþÿÿþþÿÿÿÿÿþþÿþÿÿþÿÿþþÿÿÿÿÿÿÿÿÿÿßÿÿÿÿÿÿÿþþÿþÿÿþþÿÿÿÿÿþþþþÀÿüÿÿÿþàÿøÐþÿüüøÀÿüüüþÿüôþþøÿÿÿÿÿÿÿÿÿÿþÿÿÿ÷ÿÿÿÿÿÿÿÿÿÿÿß \$\endgroup\$
    – Fowlparts
    Commented Jan 12, 2012 at 4:33
  • \$\begingroup\$ The string of symbols shown above is about 15 seconds worth of data at 4800baud. As for your second question, yes, I have tried different handshaking, including 'no handshaking.' One line in the manual (page 3-48, 3.10.3 Serial Output Data Format) suggested to me that the device responds to 'RTS/CTS' state changes. Specifically: "Drive the CTS line low to cease data transmission..." I have not messed with 'Xon/Xoff' because I'm fairly certain the serial protocol for this device isn't that advance. \$\endgroup\$
    – Fowlparts
    Commented Jan 12, 2012 at 4:44
  • \$\begingroup\$ You probably want to use a program that can capture in hex, such as Realterm to see how it looks and post to the queston. The above looks like a lot of characters in the > 0xF0 range and less than < 0x1F probably isn't shown so it may be a string of signed numbers in binary. \$\endgroup\$
    – PeterJ
    Commented Jan 25, 2013 at 10:32
  • \$\begingroup\$ That looks like seeing lots of 0xFF characters. I often see that on my hardware when either (a) I have the baud rate set wrong, or (b) my hardware puts out "RS232TTL" levels (0 = 0V, 1 = 5V, rather than standard RS232 0=+12V, 1=-12V -- I'm missing a MAX232 chip or equivalent somewhere), or both. \$\endgroup\$
    – davidcary
    Commented Oct 6, 2013 at 15:43

1 Answer 1


Here is how I would suggest going about debugging this problem:-

  1. Check the connections.. if you've mixed up signal ground and chassis ground (shield) you could get funny behavior just like you describe. Pin 7 on the DB-25 is the one you want to connect to DE-9 pin 5. I'll assume you're using a commercial adapter/cable or have one wired like this.

    enter image description here

    Maybe check the transmit out line to ensure it's idling at -12 ( < -3 anyway).

  2. Make sure the instrument is set to RS-232, and not current loop (Jumper 7,8 and 1,2).

  3. Try the most common serial port setting (9600/8-N-1), 9600 baud, NO parity, 1 stop bit switch 1, 2, 3 OFF switch 4, 5 ON switch 6 ON switch 7, 8 ON

    Make SURE you understand which is 'OFF' and which is 'ON'. Don't laugh, I've seen this happen more than once, and some types of DIP switches are kind of ambiguously marked. If in doubt, an ohmmeter across the switch.. in fact you could check all of the switches to ensure they're working.

    I like Realterm as a terminal program. It's free, and easy to change the parameters. Try it on something known working first of course, and look for an online tutorial. Really worth it.

  4. If still gibberish after that, get a scope screen cap or photo and post it.

  5. If you have a continuing need for a logic analyzer, this one is very cheap and relatively useful. Not as good as my Tektronix boat anchor, but this one will fit in a coat pocket. But I'd get a scope first if you don't have one. Even the worst scope is better than nothing.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.