1
\$\begingroup\$

I'm having a problem with my AVRISP mkII. I'm trying to program a ATMEGA328P on a breadboard using AtmelStudio 7. The problem is I can not make AVRISP detect the target. Whenever I try to program the uC, I get the warning "target not detected." The read voltage on the target is always 0,0V, and the programmer LED is always red.

I thought the AVRISP was malfunctioning, but measuring the voltage directly at the VCC and GND pins on the AVRISP board, and got the 5V supply voltage. I tested the programmer through the ICSP connector of an Arduino board, and it was automatically detected, and worked perfectly, then I think the problem is not in AVRISP.

This is the circuit that I'm assembling: enter image description here

I'm also using 100nF decoupling capacitors on Vcc pins and the Vcc Pin of AVRISP is connected with power supply.

I would like to know if there is something wrong with the schematics, or some setting to be done in AtmelStudio. I'm actually a newbie, and I'm feeling totally lost.

I've already followed the guidelines of some similar topics here, but without success...

Thanks in advance

\$\endgroup\$
  • \$\begingroup\$ First check power, then check your clock. Then recheck your pinout with a vaild pinout, like one from a dev board schematic. When you say assembling do you mean on a breadboard or a PCB. If it's on a breadboard then there are a million things that can go wrong. You job is to make sure you understand all the things that need to happen for the IC to work, then go through that list and verify that everything works. \$\endgroup\$ – Voltage Spike Aug 1 '16 at 21:44
  • \$\begingroup\$ Thanks for you comment, @laptop2d. Yes, I'm using a breadboard. I checked the clock and looks like ok. I also looked the Arduino's Uno and Micro schematics, and found some things I can try to do, so I'm reviewing my circuit. As soon as possible I'll post the result. \$\endgroup\$ – rnt_42 Aug 2 '16 at 19:41
1
\$\begingroup\$

It will of course fail to detect the target voltage, as you have left the VCC pin of the ISP connector unwired. Connect it to your ATmega's supply pin.

Leaving that signal unwired works for simple homegrown programmers (Arduino as ISP, etc) which drive signals directly from MCU pins at whatever level the MCU implementing the programmer natural drives. But more sophisticated programmers have output drivers that adjust to a range of target voltages, and so need to be fed the target voltage as a reference input.

\$\endgroup\$
  • \$\begingroup\$ My mistake. I've already connected the ISP Vcc pin to supply voltage. I didn't saw this mistake in schematic. The voltage between vcc and gnd pins of AVRISP board is actually 5V, measured with a Voltage meter. But in AtmelStudio I only got 0,0V. \$\endgroup\$ – rnt_42 Aug 1 '16 at 20:43
0
\$\begingroup\$

I am posting this just to avoid keep this post open. The problem was solved. I was confusing the pins back to front. I thought the side on red stripe was pin 1, when actually was pin 2.

I'm feeling very embarassed to know that my first question in this amazing forum was about a reason such dumb, but... living and learning...

Thank you for all the help.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.